MGRE下的OSPF实验

在这里插入图片描述

配置

R3
interface GigabitEthernet0/0/0
 ip address 192.168.3.2 255.255.255.0 
 ospf network-type p2mp
#
interface GigabitEthernet0/0/1
 ip address 34.1.1.1 255.255.255.0 
 nat outbound 2000
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface Tunnel0/0/0
 ip address 10.1.1.3 255.255.255.0 
 tunnel-protocol gre p2mp
 source GigabitEthernet0/0/1
 ospf network-type p2mp
 nhrp network-id 100
 nhrp entry 10.1.1.1 41.1.1.1 register
#
ospf 1 router-id 3.3.3.3 
 area 0.0.0.0 
  network 10.1.1.0 0.0.0.255 
  network 192.168.3.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 34.1.1.2
#
R5
interface GigabitEthernet0/0/0
 ip address 192.168.4.2 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 45.1.1.1 255.255.255.0 
 nat outbound 2000
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface Tunnel0/0/1
 ip address 10.1.2.2 255.255.255.0 
 tunnel-protocol gre p2mp
 source GigabitEthernet0/0/1
 ospf network-type broadcast
 nhrp entry multicast dynamic
 nhrp network-id 150
 nhrp entry 10.1.2.1 14.1.1.1 register
#
ospf 1 router-id 5.5.5.5 
 area 0.0.0.0 
  network 10.1.2.0 0.0.0.255 
  network 192.168.4.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 45.1.1.2
R2
interface GigabitEthernet0/0/0
 ip address 192.168.2.2 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 24.1.1.1 255.255.255.0 
 nat outbound 2000
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface Tunnel0/0/0
 ip address 10.1.1.2 255.255.255.0 
 tunnel-protocol gre p2mp
 source GigabitEthernet0/0/1
 ospf network-type p2mp
 nhrp network-id 100
 nhrp entry 10.1.1.1 41.1.1.1 register
#
ospf 1 router-id 2.2.2.2 
 area 0.0.0.0 
  network 10.1.1.0 0.0.0.255 
  network 192.168.2.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 24.1.1.2
R6
interface GigabitEthernet0/0/0
 ip address 192.168.5.1 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 46.1.1.1 255.255.255.0 
 nat outbound 2000
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface Tunnel0/0/1
 ip address 10.1.2.3 255.255.255.0 
 tunnel-protocol gre p2mp
 source GigabitEthernet0/0/1
 ospf network-type broadcast
 nhrp network-id 100
 nhrp entry 10.1.2.1 14.1.1.1 register
 nhrp entry 10.1.2.2 45.1.1.1 register
#
ospf 1 router-id 6.6.6.6 
 area 0.0.0.0 
  network 10.1.2.0 0.0.0.255 
  network 192.168.5.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 46.1.1.2
Lsp
interface GigabitEthernet0/0/0
 ip address 14.1.1.2 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 41.1.1.2 255.255.255.0 
#
interface GigabitEthernet0/0/2
 ip address 24.1.1.2 255.255.255.0 
#
interface GigabitEthernet2/0/0
 ip address 45.1.1.2 255.255.255.0 
#
interface GigabitEthernet3/0/0
 ip address 46.1.1.2 255.255.255.0 
#
interface GigabitEthernet4/0/0
 ip address 34.1.1.2 255.255.255.0 
#
interface NULL0
#
interface LoopBack0
 ip address 4.4.4.4 255.255.255.0 
R1
interface GigabitEthernet0/0/0
 ip address 192.168.1.1 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 14.1.1.1 255.255.255.0 
 nat outbound 2000
#
interface GigabitEthernet0/0/2
 ip address 41.1.1.1 255.255.255.0 
 nat outbound 2000
#
interface GigabitEthernet4/0/0
#
interface NULL0
#
interface Tunnel0/0/0
 ip address 10.1.1.1 255.255.255.0 
 tunnel-protocol gre p2mp
 source 41.1.1.1
 ospf network-type p2mp
 nhrp entry multicast dynamic
 nhrp network-id 100
#
interface Tunnel0/0/1
 ip address 10.1.2.1 255.255.255.0 
 tunnel-protocol gre p2mp
 source 14.1.1.1
 ospf network-type broadcast
 nhrp entry multicast dynamic
 nhrp network-id 150
#
ospf 1 router-id 1.1.1.1 
 area 0.0.0.0 
  network 10.1.1.0 0.0.0.255 
  network 10.1.2.0 0.0.0.255 
  network 192.168.1.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 41.1.1.2
ip route-static 0.0.0.0 0.0.0.0 14.1.1.2

测试

请添加图片描述
请添加图片描述
请添加图片描述
请添加图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值