OSPF在MGRE上的实验练习

 

R1配置:

//配置ip地址
[r1]int g0/0/0
[r1-GigabitEthernet0/0/0]ip add 12.1.1.1 24 
[r1-GigabitEthernet0/0/0]int g0/0/1
[r1-GigabitEthernet0/0/1]ip add 13.1.1.1 24
[r1]interface LoopBack 0
[r1-LoopBack0]ip add 192.168.1.1 24
//写缺省路由
[r1]ip route-static 0.0.0.0 0 12.1.1.2
[r1]ip route-static 0.0.0.0 0 13.1.1.2 preference 61
//配置MRGE结构
[r1]interface Tunnel 0/0/0
[r1-Tunnel0/0/0]ip address 192.168.6.1 24
[r1-Tunnel0/0/0]tunnel-protocol gre p2mp 
[r1-Tunnel0/0/0]source 12.1.1.1
[r1-Tunnel0/0/0]nhrp entry multicast dynamic 
[r1-Tunnel0/0/0]nhrp network-id 100
[r1-Tunnel0/0/0]nhrp entry 192.168.6.2 45.1.1.1 register 
[r1-Tunnel0/0/0]nhrp entry 192.168.6.3 56.1.1.1 register
//配置星型拓扑结构,中心站点
[r1]interface t0/0/1
[r1-Tunnel0/0/1]ip address 192.168.7.1 24
[r1-Tunnel0/0/1]tunnel-protocol gre p2mp 
[r1-Tunnel0/0/1]source 13.1.1.1	
[r1-Tunnel0/0/1]nhrp network-id 101
[r1-Tunnel0/0/1]nhrp entry multicast dynamic 
//OSPF配置
[r1]ospf 1 router-id 1.1.1.1
[r1-ospf-1]area 0
[r1-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255
[r1-ospf-1-area-0.0.0.0]network 192.168.6.0 0.0.0.255
[r1-ospf-1-area-0.0.0.0]network 192.168.7.0 0.0.0.255
//修改接口为broadcast口
[r1]int t0/0/0
[r1-Tunnel0/0/0]ospf network-type broadcast 
[r1]int t0/0/1
[r1-Tunnel0/0/0]ospf network-type broadcast 

R2配置:

//配置ip地址
[r2]int g0/0/0
[r2-GigabitEthernet0/0/0]ip add 23.1.1.1 24
[r2]interface LoopBack 0
[r2-LoopBack0]ip add 192.168.2.1 24
//写缺省路由
[r2]ip route-static 0.0.0.0 0 23.1.1.2
//配置星型拓扑结构,分支站点
[r2]interface Tunnel 0/0/1
[r2-Tunnel0/0/1]ip address 192.168.7.2 24
[r2-Tunnel0/0/1]tunnel-protocol gre p2mp 
[r2-Tunnel0/0/1]source GigabitEthernet 0/0/0
[r2-Tunnel0/0/1]nhrp network-id 101
[r2-Tunnel0/0/1]nhrp entry 192.168.7.1 13.1.1.1 register 
//OSPF配置
[r2]ospf 1 router-id 2.2.2.2
[r2-ospf-1]area 0
[r2-ospf-1-area-0.0.0.0]network 192.168.2.0 0.0.0.255
[r2-ospf-1-area-0.0.0.0]network 192.168.7.0 0.0.0.255
//修改接口为broadcast口
[r2]int t0/0/0
[r2-Tunnel0/0/0]ospf network-type broadcast 

R3配置:

//配置ip地址
[r3]int g0/0/0
[r3-GigabitEthernet0/0/0]ip add 34.1.1.1 24
[r3]interface LoopBack 0
[r3-LoopBack0]ip add 192.168.3.1 24
//写缺省路由
[r3]ip route-static 0.0.0.0 0 34.1.1.2
//配置星型拓扑结构,分支站点
[r3]interface t0/0/1
[r3-Tunnel0/0/1]ip address 192.168.7.3 24
[r3-Tunnel0/0/1]tunnel-protocol gre p2mp 
[r3-Tunnel0/0/1]source GigabitEthernet 0/0/0
[r3-Tunnel0/0/1]nhrp network-id 101
[r3-Tunnel0/0/1]nhrp entry 192.168.7.1 13.1.1.1 register 
//OSPF配置
[r3]ospf 1 router-id 3.3.3.3
[r3-ospf-1]area 0
[r3-ospf-1-area-0.0.0.0]network 192.168.3.0 0.0.0.255
[r3-ospf-1-area-0.0.0.0]network 192.168.7.0 0.0.0.255
//修改接口为broadcast口
[r3]interface Tunnel 0/0/1
[r3-Tunnel0/0/1]ospf network-type broadcast 

R4配置:

//配置ip地址
[r4]int g0/0/0
[r4-GigabitEthernet0/0/0]ip add 45.1.1.1 24
[r4]interface LoopBack 0
[r4-LoopBack0]ip add 192.168.4.1 24
//写缺省路由
[r4]ip route-static 0.0.0.0 0 45.1.1.2
//配置MRGE结构
[r4]interface Tunnel 0/0/0
[r4-Tunnel0/0/0]ip address 192.168.6.2 24
[r4-Tunnel0/0/0]tunnel-protocol gre p2mp 
[r4-Tunnel0/0/0]source 45.1.1.1
[r4-Tunnel0/0/0]nhrp entry multicast dynamic 
[r4-Tunnel0/0/0]nhrp network-id 100
[r4-Tunnel0/0/0]nhrp entry 192.168.6.1 12.1.1.1 register 
[r4-Tunnel0/0/0]nhrp entry 192.168.6.3 56.1.1.1 register
//OSPF配置
[r4]ospf 1 router-id 4.4.4.4
[r4-ospf-1]area 0
[r4-ospf-1-area-0.0.0.0]network 192.168.4.0 0.0.0.255
[r4-ospf-1-area-0.0.0.0]network 192.168.6.0 0.0.0.255
//修改接口为broadcast口
[r4]interface Tunnel 0/0/0
[r4-Tunnel0/0/0]ospf network-type broadcast 

R5配置:

//配置ip地址
[r5]int g0/0/0
[r5-GigabitEthernet0/0/0]ip add 56.1.1.1 24
[r5]interface LoopBack 0
[r5-LoopBack0]ip add 192.168.5.1 24
//写缺省路由
[r5]ip route-static 0.0.0.0 0 56.1.1.2
//配置MRGE结构,分支站点配置
[r5]interface Tunnel 0/0/0
[r5-Tunnel0/0/0]ip address 192.168.6.3 24
[r5-Tunnel0/0/0]tunnel-protocol gre p2mp 
[r5-Tunnel0/0/0]source 56.1.1.1
[r5-Tunnel0/0/0]nhrp entry multicast dynamic 
[r5-Tunnel0/0/0]nhrp network-id 100
[r5-Tunnel0/0/0]nhrp entry 192.168.6.1 12.1.1.1 register 
[r5-Tunnel0/0/0]nhrp entry 192.168.6.2 45.1.1.1 register 
//OSPF配置
[r5]ospf 1 router-id 5.5.5.5
[r5-ospf-1]area 0
[r5-ospf-1-area-0.0.0.0]network 192.168.5.0 0.0.0.255
[r5-ospf-1-area-0.0.0.0]network 192.168.6.0 0.0.0.255
//修改接口为broadcast口
[r5]interface t0/0/0
[r5-Tunnel0/0/0]ospf network-type broadcast 

R6配置:

//配置ip地址
[r6]int g0/0/0
[r6-GigabitEthernet0/0/0]ip add 12.1.1.2 24
[r6-GigabitEthernet0/0/0]int g3/0/0
[r6-GigabitEthernet3/0/0]ip add 13.1.1.2 24
[r6-GigabitEthernet3/0/0]int g0/0/1
[r6-GigabitEthernet0/0/1]ip add 23.1.1.2 24
[r6-GigabitEthernet0/0/1]int g0/0/2
[r6-GigabitEthernet0/0/2]ip add 34.1.1.2 24
[r6-GigabitEthernet0/0/2]int g1/0/0
[r6-GigabitEthernet1/0/0]ip add 45.1.1.2 24
[r6-GigabitEthernet1/0/0]int g2/0/0
[r6-GigabitEthernet2/0/0]ip add 56.1.1.2 24
[r6]interface LoopBack 0
[r6-LoopBack0]ip add 6.6.6.6 24

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值