while(scanf(“%d“,&n)!=0)的含义(zcmu1000有感)

1.记住这不代表说读取的n不等于0时可以循环,而是指这段代码中的while循环条件是判断scanf函数的返回值是否为0,而不是判断输入的值是否为0。scanf函数在成功读取到匹配的输入后会返回成功读取的参数个数,如果没有成功读取到匹配的输入,则返回0。因此,这段代码会一直循环执行,直到成功读取到一个整数并将其赋值给变量n。

Description

Your task is to Calculate the sum of some integers.

Input

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input

4 1 2 3 4 5 1 2 3 4 5 0

Sample Output

10 15

​
#include<stdio.h>
#include<string.h>
int main()
{
	int n;
	while(scanf("%d",&n)!=0&&n!=0)//所以这里如果是想要判断n是不是等于0,就要写成这个样子
	{   int sum=0;
		while(n--)
		{   int m;
		scanf("%d",&m);
			sum+=m;
		}
		printf("%d\n",sum);
	}
}

​
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值