Chili Peppers

[CCC 2023 J2] Chili Peppers

题面翻译

Ron 在尝试使用一些辣椒做一份黑暗料理,每一个辣椒都有其自己特别的辣度,如下表:

辣椒名辣度
Poblano 1500 1500 1500
Mirasol 6000 6000 6000
Serrano 15500 15500 15500
Cayenne 40000 40000 40000
Thai 75000 75000 75000
Habanero 125000 125000 125000

一份黑暗料理的辣度是根据所有辣椒辣度的总和决定的。

现在请你实现一个程序,输入的第一行为 n n n 1 ≤ n ≤ 10 1 \leq n \leq 10 1n10),表示一共放了 n n n 个辣椒,接下来 n n n 行,一行一个字符串 s i s_i si,表示放入辣椒的名称。现在请你求出那份黑暗料理的辣度。

题目描述

Ron is cooking chili using an assortment of peppers.

The spiciness of a pepper is measured in Scolville Heat Units (SHU).Ron’s chili is currently not spicy at all, but each time Ron adds a pepper, the total spiciness of the chili increases by the SHU value of that pepper.
The SHU values of the peppers available to Ron are shown in the following table:

Pepper NameScolville Heat Units
Poblano 1500 1500 1500
Mirasol 6000 6000 6000
Serrano 15500 15500 15500
Cayenne 40000 40000 40000
Thai 75000 75000 75000
Habanero 125000 125000 125000

Your job is to determine the total spiciness of Ron’s chili after he has finished adding peppers.

输入格式

The first line of input will contain a positive integer N N N, representing the number of peppers Ron adds to his chili. The next N N N lines will each contain the name of a pepper Ron has added. Each pepper name will exactly match a name that appears in the table above. Note that more than one pepper of the same name can be added.

输出格式

The output will consist of a positive integer T T T, representing the total spiciness of Ron’s chili.

样例 #1

样例输入 #1

4
Poblano
Cayenne
Thai
Poblano

样例输出 #1

118000

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <stack>//栈
// #include <deque>//队列
// #include <queue>//堆/优先队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>

using namespace std;

typedef long long ll;

int main()
{
    ll n;
    cin>>n;
    
    ll ans=0;
    for(ll i=1;i<=n;i++)
    {
        string s;
        cin>>s;
        if(s[0]=='P') ans+=1500;
        else if(s[0]=='M') ans+=6000;
        else if(s[0]=='S') ans+=15500;
        else if(s[0]=='C') ans+=40000;
        else if(s[0]=='T') ans+=75000;
        else ans+=125000;
    }
    
    cout<<ans<<endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值