Watermelon

Watermelon

题面翻译

题目描述

一个炎热的夏天,Pete 和他的朋友 Billy 感到十分口渴,于是在西瓜摊上买了一个重 w w w 公斤的西瓜。

他们回到家准备分西瓜。因为两个人都十分喜爱偶数,所以他们俩希望分出来的两块西瓜的重量都是偶数公斤。帮助他们判断是否可能做到这一点。

输入格式

一行一个整数 w   ( 0 ≤ w ≤ 100 ) w\,(0\le w\le100) w(0w100)

输出格式

如果可以按照他们的意愿分配西瓜,输出 YES;否则输出 NO

样例 #1 解释

他们可以将西瓜分成 2 2 2 公斤和 6 6 6 公斤。


翻译 By @Eason_cyx

题目描述

One hot summer day Pete and his friend Billy decided to buy a watermelon. They chose the biggest and the ripest one, in their opinion. After that the watermelon was weighed, and the scales showed $ w $ kilos. They rushed home, dying of thirst, and decided to divide the berry, however they faced a hard problem.

Pete and Billy are great fans of even numbers, that’s why they want to divide the watermelon in such a way that each of the two parts weighs even number of kilos, at the same time it is not obligatory that the parts are equal. The boys are extremely tired and want to start their meal as soon as possible, that’s why you should help them and find out, if they can divide the watermelon in the way they want. For sure, each of them should get a part of positive weight.

输入格式

The first (and the only) input line contains integer number $ w $ ( $ 1<=w<=100 $ ) — the weight of the watermelon bought by the boys.

输出格式

Print YES, if the boys can divide the watermelon into two parts, each of them weighing even number of kilos; and NO in the opposite case.

样例 #1

样例输入 #1

8

样例输出 #1

YES

提示说明

For example, the boys can divide the watermelon into two parts of 2 and 6 kilos respectively (another variant — two parts of 4 and 4 kilos).

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <sstream>//整型转字符串
// #include <stack>//栈
// #include <deque>//堆/优先队列
// #include <queue>//队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>
using namespace std;

typedef long long ll;

int main()
{
    ll n;
    cin>>n;

    if(n&1||n==2) cout<<"NO"<<endl;
    else cout<<"YES"<<endl;

    return 0;
}
  • 10
    点赞
  • 18
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值