Theatre Square

Theatre Square

题面翻译

题目描述

贝尔兰首都的剧院广场呈矩形,尺寸为 n × m n \times m n×m。在该市周年纪念日之际,人们决定用正方形的花岗岩石板铺设广场。每块石板的尺寸为 a × a a \times a a×a

铺砌广场所需的石板最少数量是多少?石板可以覆盖比剧院广场更大的表面,但必须覆盖广场。不允许打碎石板。石板的边应与广场的边平行。

输入格式

输入包含三个正整数: n n n m m m a a a($1 \le n、m、a \le 10^9 $)。

输出格式

输出所需的石板数量。

翻译者:jiangyunuo

题目描述

Theatre Square in the capital city of Berland has a rectangular shape with the size $ n×m $ meters. On the occasion of the city’s anniversary, a decision was taken to pave the Square with square granite flagstones. Each flagstone is of the size $ a×a $ .

What is the least number of flagstones needed to pave the Square? It’s allowed to cover the surface larger than the Theatre Square, but the Square has to be covered. It’s not allowed to break the flagstones. The sides of flagstones should be parallel to the sides of the Square.

输入格式

The input contains three positive integer numbers in the first line: $ n,m $ and $ a $ ( $ 1\leq n,m,a\leq10^{9} $ ).

输出格式

Write the needed number of flagstones.

样例 #1

样例输入 #1

6 6 4

样例输出 #1

4

提示说明

CF 题目提交时的注意事项:

CodeForces 不允许多次提交同样的代码。如果您如此提交将会产生提交失败错误。如您确实需要这么做,请自行添加一些注释。

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <sstream>//整型转字符串
// #include <stack>//栈
// #include <deque>//堆/优先队列
// #include <queue>//队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>
using namespace std;

typedef long long ll;

int main()
{
    ll n,m,a;
    cin>>n>>m>>a;

    ll x=ceil(n*1.0/a);
    ll y=ceil(m*1.0/a);

    cout<<x*y<<endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值