pat mooc 数据结构 01-复杂度2 Maximum Subsequence Sum

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

#include <iostream>
using namespace std;
int main()
{
    int k, i;
    int t=0, j=0, es=0;
    cin >> k;
    int max ,sum;
    int flag, sign;
    max = sum = flag = sign = 0;
    int array[10000];
    for (i = 0; i < k; i++) {
        cin >> array[i];
        if (array[i] == 0) {
            flag = 1;
        }
        else if (array[i] > 0) {
            sign = 1;
        }
        sum += array[i];
        if (sum > max) {
            max=sum;
            t = i;      //用t来记录最后一个符合要求的数在数组中的位置
            es = j;   
  
/*此处es为什么会等于j=i+1?因为如果输入是先负数,再正数的时候,可以记录第一个正数的位置,即所对应的负数的后一位*/

        }
        else if (sum < 0) {
            sum=0;
            j = i+1;    //
        }
    }
    if (flag == 0 && sign == 0) {
        cout << "0 " << array[0] << " " << array[k-1] << endl;
    }
    else if (flag == 1 && sign == 0) {
        cout << "0 " << "0 " << "0" << endl;
    }
    else {
        cout << max <<" "<< array[es] <<" "<< array[t] << endl;
    }



    return 0;
}

  • 11
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值