三个字符串排序

描述

给定三个字符串,请将它们按从小到大的顺序输出。

输入

输入为一行,包含三个字符串,用空格分隔。

输出

输出为一行,包含三个字符串,用空格分隔,表示排序后的结果。

输入样例 1 

banana apple orange

输出样例 1

apple banana orange

输入样例 2 

java python c++

输出样例 2

c++ java python

输入样例 3 

programming algorithm function

输出样例 3

algorithm function programming

代码一(如下):字符串数组法

#include <iostream>
#include <string>
using namespace std;
int main()
{
	string a[3],t;
	for (int i = 0; i < 3; i++)
	{
		cin >> a[i];
	}
	if (a[0] > a[1])
	{
		t = a[0]; a[0] = a[1]; a[1] = t;
	}
	if (a[0] > a[2])
	{
		t = a[0]; a[0] = a[2]; a[2] = t;
	}
	if (a[1] > a[2])
	{
		t = a[1];a[1] = a[2];a[2] = t;
	}
	for (int i = 0; i < 3; i++)
	{
		cout << a[i] << " ";
	}
	return 0;
}

代码二(如下):字符串数组+冒泡排序

#include <iostream>
#include <string>
using namespace std;
int main()
{
	string a[3],t;
	for (int i = 0; i < 3; i++)
	{
		cin >> a[i];
	}
	for (int i = 1; i < 3; i++)
	{
		for (int j = 0; j < 3 - i; j++)
		{
			if (a[j] > a[j + 1])
			{
				t = a[j];
				a[j] = a[j + 1];
				a[j + 1] = t;
			}
		}
	}
	for (int i = 0; i < 3; i++)
	{
		cout << a[i] << " ";
	}
	return 0;
}

代码三(如下):字符数组

#include <iostream>
#include <string>
using namespace std;
int main()
{
	char a[3][20],c[20];
	for (int i = 0; i < 3; i++)
	{
		cin >> a[i];
	}
	if (strcmp(a[0], a[1]) > 0)
	{
		strcpy_s(c, a[0]);
		strcpy_s(a[0], a[1]);
		strcpy_s(a[1], c);
	}
	if (strcmp(a[0], a[2]) > 0)
	{
		strcpy_s(c, a[0]);
		strcpy_s(a[0], a[2]);
		strcpy_s(a[2], c);
	}
	if (strcmp(a[1], a[2]) > 0)
	{
		strcpy_s(c, a[1]);
		strcpy_s(a[1], a[2]);
		strcpy_s(a[2], c);
	}
	for (int i = 0; i < 3; i++)
	{
		cout << a[i] << " ";
	}
	return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值