BGP作业

步骤一:根据要求合理划分网段

根据要求首先我们要对AS2区域进行网段的划分基于172.16.0.0/16,可以进行如下图的划分

将172.16.0.0/16划到24位的网络位取172.16.1.0 24网段进行路由器之间连线的网段划分至少要划分6个网段用于连线,故保留29位网络位取8个网段,分别为 0 8 16 24 32 40 48 56;对于AS2区域中的路由器的环回取对应编号的网段,例如R2:172.16.2.0 24   R3:172.16.3.0 24 ,其余网段如上图所示;R1和R8都有一个固定的环回网段,另外的R1环回网段设置为10.0.0.0 24 R2的环回网段设置为20.0.0.0 24

步骤二:对每个路由的接口和环回接口进行ip配置

[r1]interface g 0/0/0
[r1-GigabitEthernet0/0/0]ip address 12.0.0.1 24
[r1]interface LoopBack 0
[r1-LoopBack0]ip address 192.168.1.1 24
[r1]interface LoopBack 1
[r1-LoopBack1]ip address 10.0.0.1 24


[r2]interface g 0/0/0
[r2-GigabitEthernet0/0/0]ip address 12.0.0.2 24
[r2]interface g 0/0/1
[r2-GigabitEthernet0/0/1]ip address 172.16.1.1 29
[r2]interface g 0/0/2
[r2-GigabitEthernet0/0/2]ip address 172.16.1.9 29
[r2]interface LoopBack 0
[r2-LoopBack0]ip address 172.16.2.1 24


[r3]interface g 0/0/0
[r3-GigabitEthernet0/0/0]ip address 172.16.1.2 29
[r3]interface g 0/0/1
[r3-GigabitEthernet0/0/1]ip address 172.16.1.17 29
[r3]interface LoopBack 0
[r3-LoopBack0]ip address 172.16.3.1 24


[r4]interface g 0/0/0
[r4-GigabitEthernet0/0/0]ip address 172.16.1.18 29
[r4]interface g 0/0/1
[r4-GigabitEthernet0/0/1]ip address 172.16.1.25 29
[r4]interface LoopBack 0
[r4-LoopBack0]ip address 172.16.4.1 24


[r5]interface g 0/0/0
[r5-GigabitEthernet0/0/0]ip address 172.16.1.10 29
[r5]interface g 0/0/1
[r5-GigabitEthernet0/0/1]ip address 172.16.1.33 29
[r5]interface LoopBack 0
[r5-LoopBack0]ip address 172.16.5.1 24


[r6]interface g 0/0/0
[r6-GigabitEthernet0/0/0]ip address 172.16.1.34 29
[r6]interface g 0/0/1
[r6-GigabitEthernet0/0/1]ip address 172.16.1.41 29
[r6]interface LoopBack 0
[r6-LoopBack0]ip address 172.16.6.1 24


[r7]interface g 0/0/0
[r7-GigabitEthernet0/0/0]ip address 172.16.1.42 29
[r7]interface g 0/0/1
[r7-GigabitEthernet0/0/1]ip address 172.16.1.26 29
[r7]interface g 0/0/2
[r7-GigabitEthernet0/0/2]ip address 78.0.0.1 24
[r7]interface LoopBack 0
[r7-LoopBack0]ip address 172.16.7.1 24


[r8]interface g 0/0/0
[r8-GigabitEthernet0/0/0]ip address 78.0.0.2 24
[r8]interface LoopBack 0
[r8-LoopBack0]ip address 192.168.2.1 24
[r8]interface LoopBack 1
[r8-LoopBack1]ip address 20.0.0.1 24

步骤三:对AS2区域配置OSPF

[r2]ospf 1 router-id 2.2.2.2
[r2-ospf-1]area 0
[r2-ospf-1-area-0.0.0.0]network 172.16.0.0 0.0.255.255


[r3]ospf 1 router-id 3.3.3.3
[r3-ospf-1]area 0
[r3-ospf-1-area-0.0.0.0]network 172.16.0.0 0.0.255.255


[r4]ospf 1 router-id 4.4.4.4
[r4-ospf-1]area 0
[r4-ospf-1-area-0.0.0.0]network 172.16.0.0 0.0.255.255


[r5]ospf 1 router-id 5.5.5.5
[r5-ospf-1]area 0
[r5-ospf-1-area-0.0.0.0]network 172.16.0.0 0.0.255.255


[r6]ospf 1 router-id 6.6.6.6
[r6-ospf-1]area 0
[r6-ospf-1-area-0.0.0.0]network 172.16.0.0 0.0.255.255


[r7]ospf 1 router-id 7.7.7.7
[r7-ospf-1]area 0
[r7-ospf-1-area-0.0.0.0]network 172.16.0.0 0.0.255.255

检查查看是否配错配漏

步骤四:配置BGP建立对等体

[r1]bgp 1
[r1-bgp]router-id 1.1.1.1 
[r1-bgp]peer 12.0.0.2 as 2




[r2]bgp 64512
[r2-bgp]router-id 2.2.2.2
[r2-bgp]confederation id 2	
[r2-bgp]confederation peer-as 64513
[r2-bgp]peer 12.0.0.1 as 1
[r2-bgp]peer 12.0.0.1 ebgp-max-hop 2
[r2-bgp]peer 172.16.3.1 as 64512
[r2-bgp]peer 172.16.3.1 connect-interface LoopBack 0
[r2-bgp]peer 172.16.5.1 as 64513
[r2-bgp]peer 172.16.5.1 connect-interface LoopBack 0
[r2-bgp]peer 172.16.5.1 ebgp-max-hop 2
[r2-bgp]peer 172.16.3.1 next-hop-local
[r2-bgp]peer 172.16.5.1 next-hop-local



[r3]bgp 64512
[r3-bgp]router-id 3.3.3.3	
[r3-bgp]confederation id 2
[r3-bgp]peer 172.16.2.1 as 64512
[r3-bgp]peer 172.16.2.1 connect-interface LoopBack 0
[r3-bgp]peer 172.16.4.1 as 64512
[r3-bgp]peer 172.16.4.1 connect-interface LoopBack 0


[r4]bgp 64512
[r4-bgp]router-id 4.4.4.4
[r4-bgp]confederation id 2
[r4-bgp]confederation peer-as 64513
[r4-bgp]peer 172.16.3.1 as 64512
[r4-bgp]peer 172.16.3.1 connect-interface LoopBack 0
[r4-bgp]peer 172.16.7.1 as 64513
[r4-bgp]peer 172.16.7.1 connect-interface LoopBack 0
[r4-bgp]peer 172.16.7.1 ebgp-max-hop 2


[r5]bgp 64513
[r5-bgp]router-id 5.5.5.5
[r5-bgp]confederation id 2
[r5-bgp]confederation peer-as 64512
[r5-bgp]peer 172.16.2.1 as 64512
[r5-bgp]peer 172.16.2.1 connect-interface LoopBack 0
[r5-bgp]peer 172.16.2.1 ebgp-max-hop 2
[r5-bgp]peer 172.16.6.1 as 64513 
[r5-bgp]peer 172.16.6.1 connect-interface LoopBack 0


[r6]bgp 64513
[r6-bgp]router-id 6.6.6.6
[r6-bgp]confederation id 2
[r6-bgp]peer 172.16.5.1 as 64513
[r6-bgp]peer 172.16.5.1 connect-interface LoopBack 0
[r6-bgp]peer 172.16.7.1 as 64513
[r6-bgp]peer 172.16.7.1 connect-interface LoopBack 0


[r7]bgp 64513
[r7-bgp]router-id 7.7.7.7
[r7-bgp]confederation id 2	
[r7-bgp]confederation peer-as 64512
[r7-bgp]peer 78.0.0.2 as 3	
[r7-bgp]peer 78.0.0.2 ebgp-max-hop 2
[r7-bgp]peer 172.16.6.1 as 64513
[r7-bgp]peer 172.16.6.1 connect-interface LoopBack 0
[r7-bgp]peer 172.16.4.1 as 64512
[r7-bgp]peer 172.16.4.1 connect-interface LoopBack 0
[r7-bgp]peer 172.16.4.1 ebgp-max-hop 2
[r7-bgp]peer 172.16.4.1 next-hop-local
[r7-bgp]peer 172.16.6.1 next-hop-local



[r8]bgp 3
[r8-bgp]router-id 8.8.8.8
[r8-bgp]peer 78.0.0.1 as 2





步骤五:发布路由(R1、R8)

[r1]bgp 1
[r1-bgp]network 10.0.0.0 24
[r1-bgp]network 192.168.1.0 24


[r8]bgp 3	
[r8-bgp]network 20.0.0.0 24
[r8-bgp]network 192.168.2.0 24

步骤六:配置路由反射器(R3、R6)

[r3]bgp 64512
[r3-bgp]peer 172.16.2.1 reflect-client
[r3-bgp]peer 172.16.4.1 reflect-client 


[r6]bgp 64513
[r6-bgp]peer 172.16.7.1 reflect-client 
[r6-bgp]peer 172.16.5.1 reflect-client 

步骤七:空接口、汇总、宣告(主要是防环)

[r2]ip route-static 172.16.0.0 21 NULL 0
[r2]bgp 64512
[r2-bgp]network 172.16.0.0 21


[r7]ip route-static 172.16.0.0 21 NULL 0
[r7]bgp 64513
[r7-bgp]network 172.16.0.0 21

步骤八:创建GRE隧道

[r1]interface Tunnel 0/0/0
[r1-Tunnel0/0/0]ip address 192.168.10.1 24	
[r1-Tunnel0/0/0]tunnel-protocol gre
[r1-Tunnel0/0/0]source 10.0.0.1
[r1-Tunnel0/0/0]description 20.0.0.1
[r1-Tunnel0/0/0]q
[r1]ip route-static 192.168.2.0 24 100.0.0.2


[r8]interface Tunnel 0/0/0
[r8-Tunnel0/0/0]ip address 192.168.10.2 24
[r8-Tunnel0/0/0]tunnel-protocol gre
[r8-Tunnel0/0/0]source 20.0.0.1
[r8-Tunnel0/0/0]description 10.0.0.1
[r8-Tunnel0/0/0]q
[r8]ip route-static 192.168.1.0 24 100.0.0.1

验证:

[r1]ping -a 192.168.1.1 192.168.2.1
  PING 192.168.2.1: 56  data bytes, press CTRL_C to break
    Reply from 192.168.2.1: bytes=56 Sequence=1 ttl=255 time=110 ms
    Reply from 192.168.2.1: bytes=56 Sequence=2 ttl=255 time=50 ms
    Reply from 192.168.2.1: bytes=56 Sequence=3 ttl=255 time=40 ms
    Reply from 192.168.2.1: bytes=56 Sequence=4 ttl=255 time=40 ms
    Reply from 192.168.2.1: bytes=56 Sequence=5 ttl=255 time=30 ms

  --- 192.168.2.1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round-trip min/avg/max = 30/54/110 ms

[r1]
 

  • 4
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值