第三章作业

1.配ip,配置环回,缺省

配ip
[R1-Serial4/0/0]ip address 15.1.1.1 24
[R1-GigabitEthernet0/0/0]ip address 192.168.1.254 24
[R2-Serial4/0/0]ip address 25.1.1.2 24
[R2-GigabitEthernet0/0/0]ip address 192.168.2.254 24
[R3-Serial4/0/0]ip address 35.1.1.3 24
[R3-GigabitEthernet0/0/0]ip address 192.168.3.254 24
[R4-GigabitEthernet0/0/1]ip address 192.168.4.254 24
[R4-GigabitEthernet0/0/0] ip address 45.1.1.4 24
[R5-Serial4/0/1]ip address 15.1.1.5 24
[R5-Serial4/0/0]ip address 35.1.1.5 24
[R5-Serial3/0/1]ip address 25.1.1.5 24
[R5-GigabitEthernet0/0/0]ip address 45.1.1.5 24

配置环回
[R5]interface LoopBack 0
[R5-LoopBack0]ip address 5.5.5.5 24

配置缺省
[R1]ip route-static 0.0.0.0 0 15.1.1.5
[R2]ip route-static 0.0.0.0 0 25.1.1.5
[R3]ip route-static 0.0.0.0 0 35.1.1.5
[R4]ip route-static 0.0.0.0 0 45.1.1.5
 
检查是否能够成功访问公网
[R4]ping 15.1.1.1 
  PING 15.1.1.1: 56  data bytes, press CTRL_C to break
    Reply from 15.1.1.1: bytes=56 Sequence=1 ttl=254 time=90 ms
    Reply from 15.1.1.1: bytes=56 Sequence=2 ttl=254 time=30 ms
    Reply from 15.1.1.1: bytes=56 Sequence=3 ttl=254 time=20 ms
    Reply from 15.1.1.1: bytes=56 Sequence=4 ttl=254 time=30 ms
    Reply from 15.1.1.1: bytes=56 Sequence=5 ttl=254 time=30 ms
 
  --- 15.1.1.1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round-trip min/avg/max = 20/40/90 ms
 

2.进行服务认证

一.R2和R5之间进行ppp的chap认证
1.主认证方
[R5]aaa
[R5-aaa]local-user xiaotudoudou password cipher xtdd12345
Info: Add a new user.
[R5-aaa]local-user xiaotudoudou service-type ppp
[R5-aaa]q
[R5]int s 3/0/1
[R5-Serial3/0/1]ppp authentication-mode chap

2.被认证方
[R2]interface Serial 4/0/0
[R2-Serial4/0/0]ppp chap user xiaotudoudou
[R2-Serial4/0/0]ppp chap password cipher xtdd12345


二.R1和R5之间进行ppp的pap认证
 1.主认证方
[R5]aaa
[R5-aaa]local-user xiaotudou password cipher xtd12345
Info: Add a new user.
[R5-aaa]local-user xiaotudou service-type ppp
[R5-aaa]q
[R5]int Serial 4/0/1
[R5-Serial4/0/1]ppp authentication-mode pap
[R5-Serial4/0/1]

2.被认证方
[R1]interface Serial 4/0/0
[R1-Serial4/0/0]ppp pap local-user xiaotudou password cipher xtd12345
 

三.R3和R5之间使用HDLC封装
[R3-Serial4/0/0]link-protocol hdlc 
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]
:y
[R5-Serial4/0/0]link-protocol hdlc 
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]
:y


3.R1、R2、R3构建一个MGRE环境,R1为中心站点,R1、R4间为点到点的GRE

一.R1、R4间为点到点的GRE
[R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/0]ip address 10.1.1.1 24
[R1-Tunnel0/0/0]tunnel-protocol gre
[R1-Tunnel0/0/0]source 15.1.1.1
[R1-Tunnel0/0/0]description 45.1.1.4
 
[R4]interface Tunnel 0/0/0
[R4-Tunnel0/0/0]ip address 10.1.1.4 24
[R4-Tunnel0/0/0]tunnel-protocol gre
[R4-Tunnel0/0/0]source 45.1.1.4
[R4-Tunnel0/0/0]description 15.1.1.1
 
 
二.R1、R2、R3构建一个MGRE环境,R1为中心站点
[R1]interface Tunnel 0/0/1
[R1-Tunnel0/0/1]ip address 10.1.2.1 24
[R1-Tunnel0/0/1]tunnel-protocol gre p2mp 
[R1-Tunnel0/0/1]source 15.1.1.1
Mar 30 2024 14:34:28-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/1 has entered the UP state. 
[R1-Tunnel0/0/1]nhrp network-id 100
 
[R2]interface Tunnel 0/0/1
[R2-Tunnel0/0/1]ip address 10.1.2.2 24
[R2-Tunnel0/0/1]tunnel-protocol gre p2mp 
[R2-Tunnel0/0/1]source Serial 4/0/0
Mar 30 2024 14:36:43-08:00 R2 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/1 has entered the UP state. 	
[R2-Tunnel0/0/1]nhrp network-id 100
[R2-Tunnel0/0/1]nhrp entry 10.1.2.1 15.1.1.1 register 
 
[R3]interface Tunnel 0/0/1
[R3-Tunnel0/0/1]ip address 10.1.2.3 24
[R3-Tunnel0/0/1]tunnel-protocol gre p2mp 
[R3-Tunnel0/0/1]source Serial 4/0/0
Mar 30 2024 14:41:28-08:00 R3 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/1 has entered the UP state. 
[R3-Tunnel0/0/1]nhrp network-id 100
[R3-Tunnel0/0/1]nhrp entry 10.1.2.1 15.1.1.1 register 
 
查看配置信息
[R1]display ip interface brief 
*down: administratively down
^down: standby
(l): loopback
(s): spoofing
The number of interface that is UP in Physical is 5
The number of interface that is DOWN in Physical is 3
The number of interface that is UP in Protocol is 5
The number of interface that is DOWN in Protocol is 3
 
Interface                         IP Address/Mask      Physical   Protocol  
GigabitEthernet0/0/0              192.168.1.254/24     up         up        
GigabitEthernet0/0/1              unassigned           down       down      
GigabitEthernet0/0/2              unassigned           down       down      
NULL0                             unassigned           up         up(s)     
Serial4/0/0                       15.1.1.1/24          up         up        
Serial4/0/1                       unassigned           down       down      
Tunnel0/0/0                       10.1.1.1/24          up         up        
Tunnel0/0/1                       10.1.2.1/24          up         up        

4.通过rip协议让私网全网通

[R1]rip 10
[R1-rip-10]version 1
[R1-rip-10]network 192.168.1.0
[R1-rip-10]network  10.0.0.0
[R1-rip-10]undo summary 
[R1]interface Tunnel 0/0/1
[R1-Tunnel0/0/1] nhrp entry multicast dynamic
[R1-Tunnel0/0/1]undo rip split-horizon
[R1-Tunnel0/0/0]undo rip split-horizon
 
[R2]rip 10
[R2-rip-10]version 1
[R2-rip-10]network 192.168.2.0
[R2-rip-10]network 10.0.0.0
[R2-rip-10]undo summary
[R2-rip-10]q
[R2]interface Tunnel 0/0/1
[R2-Tunnel0/0/1]undo rip split-horizon 
 
[R3]rip 10
[R3-rip-10]version 1
[R3-rip-10]network 192.168.3.0
[R3-rip-10]network 10.0.0.0
[R3-rip-10]undo summary 
[R3-rip-10]q
[R3]interface Tunnel 0/0/1
[R3-Tunnel0/0/1]undo rip split-horizon 
[R3-Tunnel0/0/1]q
 
[R4]rip 1
[R4-rip-1]version 2
[R4-rip-1]undo summary 
[R4-rip-1]network 192.168.4.0 
[R4-rip-1]network 10.0.0.0
[R4-rip-1]q
[R4]interface Tunnel 0/0/0
[R4-Tunnel0/0/0]undo rip split-horizon 
[R4-Tunnel0/0/0]
 
 
 
验证是否通网
PC>ping 192.168.2.6
 
Ping 192.168.2.6: 32 data bytes, Press Ctrl_C to break
Request timeout!
From 192.168.2.6: bytes=32 seq=2 ttl=126 time=15 ms
From 192.168.2.6: bytes=32 seq=3 ttl=126 time=16 ms
From 192.168.2.6: bytes=32 seq=4 ttl=126 time=15 ms
From 192.168.2.6: bytes=32 seq=5 ttl=126 time=31 ms

5.所有PC设置私有IP为源IP,可以访问R5环回,达到全网通

[R1]acl 2000
[R1-acl-basic-2000]rule permit source 192.168.1.0 0.0.0.255
[R1-acl-basic-2000]q
[R1]interface Serial 4/0/0
[R1-Serial4/0/0]nat outbound 2000
[R1-Serial4/0/0]
 
 
[R2]acl 2000
[R2-acl-basic-2000]rule permit source 192.168.2.0 0.0.0.255
[R2-acl-basic-2000]q
[R2]interface Serial 4/0/0
[R2-Serial4/0/0]nat outbound 2000
 
[R3]acl 2000
[R3-acl-basic-2000]rule permit source 192.168.3.0 0.0.0.255
[R3-acl-basic-2000]q
[R3]interface Serial 4/0/0
[R3-Serial4/0/0]nat outbound 2000
 
[R4]acl 2000
[R4-acl-basic-2000]rule permit source 192.168.4.0 0.0.0.255
[R4-acl-basic-2000]q
[R4]interface GigabitEthernet 0/0/0
[R4-GigabitEthernet0/0/0]nat outbound 2000
 
 
 
PC>ping 5.5.5.5
 
Ping 5.5.5.5: 32 data bytes, Press Ctrl_C to break
From 5.5.5.5: bytes=32 seq=1 ttl=254 time=16 ms
From 5.5.5.5: bytes=32 seq=2 ttl=254 time=31 ms
From 5.5.5.5: bytes=32 seq=3 ttl=254 time=15 ms
From 5.5.5.5: bytes=32 seq=4 ttl=254 time=32 ms
From 5.5.5.5: bytes=32 seq=5 ttl=254 time=15 ms
 
--- 5.5.5.5 ping statistics ---
  5 packet(s) transmitted
  5 packet(s) received
  0.00% packet loss
  round-trip min/avg/max = 15/21/32 ms
 
PC>

第三章笔记:“

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值