洛谷P2853-[USACO06DEC]-Cow Picnic S

[USACO06DEC] Cow Picnic S

题目描述

The cows are having a picnic! Each of Farmer John’s K (1 ≤ K ≤ 100) cows is grazing in one of N (1 ≤ N ≤ 1,000) pastures, conveniently numbered 1…N. The pastures are connected by M (1 ≤ M ≤ 10,000) one-way paths (no path connects a pasture to itself).

The cows want to gather in the same pasture for their picnic, but (because of the one-way paths) some cows may only be able to get to some pastures. Help the cows out by figuring out how many pastures are reachable by all cows, and hence are possible picnic locations.

K ( 1 ≤ K ≤ 100 ) K(1 \le K \le 100) K(1K100) 只奶牛分散在 N ( 1 ≤ N ≤ 1000 ) N(1 \le N \le 1000) N(1N1000) 个牧场.现在她们要集中起来进餐。牧场之间有 M ( 1 ≤ M ≤ 10000 ) M(1 \le M \le 10000) M(1M10000) 条有向路连接,而且不存在起点和终点相同的有向路.她们进餐的地点必须是所有奶牛都可到达的地方。那么,有多少这样的牧场可供进食呢?

输入格式

Line 1: Three space-separated integers, respectively: K, N, and M

Lines 2…K+1: Line i+1 contains a single integer (1…N) which is the number of the pasture in which cow i is grazing.

Lines K+2…M+K+1: Each line contains two space-separated integers, respectively A and B (both 1…N and A != B), representing a one-way path from pasture A to pasture B.

输出格式

Line 1: The single integer that is the number of pastures that are reachable by all cows via the one-way paths.

样例 #1

样例输入 #1

2 4 4
2
3
1 2
1 4
2 3
3 4

样例输出 #1

2

提示

The cows can meet in pastures 3 or 4.

#include<iostream>
#include<vector>
#include<queue>
#include<cstring>
using namespace std;
const int M = 1e4 + 10;
const int N = 1e3 + 10;

vector<int> e[M];	//二维vector存图
int k, n, m;
int Num[N];			//存能到达地方的奶牛的数量:如果这里有k个奶牛到了,那就是题目所要求的点
bool st[N];	

void dfs(int x) {		//深搜,单独对一个奶牛所能到达的所有地方搜一遍,并且把它能到达的地方的Num[]加一
	st[x] = true;		//先标记此点走过

	for (int i = 0; i < e[x].size(); i++) {
		int j = e[x][i];

		if (!st[j]) {
			Num[j]++;
			dfs(j);
		}

	}
}

int main() {
	ios::sync_with_stdio(false);
	cin.tie(0);
	cin >> k >> n >> m;

	queue<int>q1;		//用队列存奶牛的初始点位(想起来用队列是因为一开始写成bfs了)

	for (int i = 0; i < k; i++) {
		int a;
		cin >> a;
		Num[a]++;	//初始位置的Num[]要加一
		q1.push(a);	//压入队列
	}

	for (int i = 0; i < m; i++) {	//建图
		int a, b;
		cin >> a >> b;
		e[a].push_back(b);
	}

	while (q1.size()) {		//对所有奶牛进行dfs
		dfs(q1.front());
		q1.pop();
		memset(st,0,sizeof st);	//每次大法师之后要初始化st数组,因为下一只奶牛可能走重
	}

	int ans = 0;
	for (int i = 1; i <= n; i++) {	//最后对达到要求的牧场进行计数
		if (Num[i] == k)ans++;
	}

	printf("%d",ans);
	return 0;
}
  • 18
    点赞
  • 20
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值