题目描述
涉及违规内容,已屏蔽。
输入
两个正整数m和n。
输出
m和n的最大公约数和最小公倍数,最小公倍数在int的表示范围内。
样例输入
14 21样例输出
the greatest common divisor is 7 the least common multiple is 42
代码如下
#include<iostream>
using namespace std;
int f1(int m, int n);
int main()
{
int m, n;
cin >> m >> n;
printf("the greatest common divisor is %d\n", f1(m, n));
printf("the least common multiple is %d", m * (n / f1(m, n)));
return 0;
}
int f1(int m, int n)
{
return m % n == 0 ? n : f1(n, m % n);
}