最大公约数#C++

题目描述

涉及违规内容,已屏蔽。

输入

两个正整数m和n。

输出

m和n的最大公约数和最小公倍数,最小公倍数在int的表示范围内。

样例输入 
14 21
样例输出 
the greatest common divisor is 7
the least common multiple is 42

代码如下

#include<iostream>
using namespace std;

int f1(int m, int n);

int main()
{
	int m, n;
	cin >> m >> n;
	printf("the greatest common divisor is %d\n", f1(m, n));
	printf("the least common multiple is %d", m * (n / f1(m, n)));
	return 0;
}

int f1(int m, int n)
{
	return m % n == 0 ? n : f1(n, m % n);
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

念帝

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值