java学习第十九天(接口 四则运算)

利用接口做参数,写个计算器,能完成加减乘除运算。
1.定义一个接口ICompute含有一个方法int computer(int n, int m)。
2.定义Add类实现接口ICompute,实现computer方法,求m,n之和
4.定义Sub类实现接口ICompute,实现computer方法,求n-m之差
5.定义Main类,在里面输入两个整数a, b,利用Add类和Sub类的computer方法,求第一个数a和第二个数b之和,输出和,第一个数a和第二个数b之差,输出差。

输入格式:
输入在一行中给出2个整数

输出格式:
输出两个数的和、差

输入样例:
在这里给出一组输入。例如:
2 3

输出样例:
在这里给出相应的输出。例如:
5
-1

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        int a,b;
        Scanner sc = new Scanner(System.in);
        a = sc.nextInt();
        b = sc.nextInt();
        Add ad = new Add();
        Sub sb = new Sub();
        System.out.println(ad.computer(a,b));
        System.out.println(sb.computer(a,b));

    }
}
interface ICompute {
     int computer(int n, int m);
}
public class Add implements ICompute{
    @Override
    public int computer(int n, int m) {
        return n+m;
    }
}

public class Sub implements ICompute{
    @Override
    public int computer(int n, int m) {
        return n-m;
    }
}


  • 3
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值