2023.9.20

A.Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 264131    Accepted Submission(s): 67863


 

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000 , 1 <= n <= 100,000,000 ). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
 
 
1 1 3 1 2 10 0 0 0
 

Sample Output
 
 
2 5
 

Author
CHEN, Shunbao
 

Source
 

一眼暴力算,但时间空间不允许

可加两个优化

1.例如8,15,22对7取模结果都是1,记录下1就可以

2.数据具有周期性,最极端的情况是循环周期为7*7=49

杭电ACM刷题(2):1005,Number Sequence_杭电number sequence_hongbin_xu的博客-CSDN博客 

 

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 101224    Accepted Submission(s): 44723


 

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
 
 
0 1 2 3 4 5
 

Sample Output
 
 
no no yes no no no
 

Author 
Leojay
和A类似
但是规律可以继续找
发现n%4==2为答案

C.Repeating Cipher

#include<bits/stdc++.h>
using namespace std;
int n,num[60],sum;
string s;
int main()
{
	scanf("%d",&n);
	cin>>s;
	for(int i=1;i<=10;i++)
	{
		sum+=i;
		num[sum]=i; 
	}
	sum=0;
	for(int i=1;i<=num[n];i++)
	{
		sum+=i;
		cout<<s[sum-1];
	}
	return 0;
}

D.Array Stabilization 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值