作者 CHEN, Yue
单位 浙江大学
每个 PAT 考生在参加考试时都会被分配两个座位号,一个是试机座位,一个是考试座位。正常情况下,考生在入场时先得到试机座位号码,入座进入试机状态后,系统会显示该考生的考试座位号码,考试时考生需要换到考试座位就座。但有些考生迟到了,试机已经结束,他们只能拿着领到的试机座位号码求助于你,从后台查出他们的考试座位号码。
输入格式:
输入第一行给出一个正整数 N(≤1000),随后 N 行,每行给出一个考生的信息:准考证号 试机座位号 考试座位号
。其中准考证号
由 16 位数字组成,座位从 1 到 N 编号。输入保证每个人的准考证号都不同,并且任何时候都不会把两个人分配到同一个座位上。
考生信息之后,给出一个正整数 M(≤N),随后一行中给出 M 个待查询的试机座位号码,以空格分隔。
输出格式:
对应每个需要查询的试机座位号码,在一行中输出对应考生的准考证号和考试座位号码,中间用 1 个空格分隔。
输入样例:
4
3310120150912233 2 4
3310120150912119 4 1
3310120150912126 1 3
3310120150912002 3 2
2
3 4
输出样例:
3310120150912002 2
3310120150912119 1
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
思路:一个学生有学号,试机座位,考试座位,三个变量,学号有16位,考虑用string处理,另外两个用int表示,类型不同,所以用结构体来存储学生的变量
struct student
{
string xuehao;
int seat1;
int seat2;
};
然后创建n(学生人数)个结构体数组,并且接受输入
cin >> n;
//student stu[100];
vector<student> stu(n);
for (int i = 0; i < n; i++)
{
cin >> stu[i].xuehao >> stu[i].seat1 >> stu[i].seat2;
}
然后接收m个待查询的试机座位号,并且根据接受的数据,回学生的结构体数组中遍历寻找,找到学生在数组里的下标
int findindex(vector<student>& stu,int x)
{
for (int i = 0; i < n; i++)
{
if (stu[i].seat1 == x)
{
return i;
}
}
}
然后按要求输出
for (int i = 0; i < m; i++)
{
int temp = findindex(stu,f[i]);
cout << stu[temp].xuehao << " " << stu[temp].seat2 << endl;
}
完整代码:
#include <algorithm>
#include <vector>
#include <iostream>
using namespace std;
struct student
{
string xuehao;
int seat1;
int seat2;
};
int n;
int findindex(vector<student>& stu,int x)
{
for (int i = 0; i < n; i++)
{
if (stu[i].seat1 == x)
{
return i;
}
}
}
int main()
{
cin >> n;
//student stu[100];
vector<student> stu(n);
for (int i = 0; i < n; i++)
{
cin >> stu[i].xuehao >> stu[i].seat1 >> stu[i].seat2;
}
int m;
cin >> m;
//int f[100] = { 0 };
vector<int> f(m,0);
for (int i = 0; i < m; i++)
{
cin >> f[i];
}
for (int i = 0; i < m; i++)
{
int temp = findindex(stu,f[i]);
cout << stu[temp].xuehao << " " << stu[temp].seat2 << endl;
}
return 0;
}