MGRE实验

1、实验拓扑图:

2、实验要求:
        1、R5为ISP,只能进行IP地址配置,其所有地址均配为公有IP地址;
        2、R1和R5间使用ppp的PAP认证,R5为主认证方;
        3、R1、R2、R3构建一个MGRE环境,R1为中心站点,R1、R4间为点到点的GRE;
        4、整个私有网络基本RIP全网可达;
        5、所有pc设置私有IP为源IP,可以访问R5环回,达到全网可达。

3、配置接口IP:
R1:

[R1]interface g0/0/0
[R1-GigabitEthernet0/0/0]ip address 192.168.1.3 24
[R1]interface Serial 4/0/0    
[R1-Serial4/0/0]ip address 15.1.1.1 24
[R1]display ip interface brief    # 查看接口IP是否配置成功

R2:

[R2]interface g0/0/0
[R2-GigabitEthernet0/0/0]ip address 192.168.2.3 24
[R2]interface Serial 4/0/0    
[R2-Serial4/0/0]ip address 25.1.1.1 24

R3:

 
  1. [R3]interface g0/0/0

  2. [R3-GigabitEthernet0/0/0]ip address 192.168.3.3 24

  3. [R3]interface Serial 4/0/0

  4. [R3-Serial4/0/0]ip address 35.1.1.1 24

R4:

[R4]interface g0/0/1
[R4-GigabitEthernet0/0/1]ip address 192.168.4.3 24
[R4]interface g0/0/0    
[R4-GigabitEthernet0/0/0]ip address 45.1.1.2 24

R5:

[R5]interface LoopBack 0
[R5-LoopBack0]ip address 5.5.5.5 24
[R5]interface Serial 4/0/0    
[R5-Serial4/0/0]ip address 35.1.1.2 24
[R5]interface Serial 3/0/1
[R5-Serial3/0/1]ip address 25.1.1.2 24
[R5]interface Serial 4/0/1
[R5-Serial4/0/1]ip address 15.1.1.2 24
[R5]interface g0/0/0
[R5-GigabitEthernet0/0/0]ip address 192.168.1.1 24

4、R1 R2 R3 R4缺省路由:
[R1]ip route-static 0.0.0.0 0 15.1.1.2
[R2]ip route-static 0.0.0.0 0 25.1.1.2
[R3]ip route-static 0.0.0.0 0 35.1.1.2
[R4]ip route-static 0.0.0.0 0 45.1.1.1
5、配置NAT进行地址转换:
R1:

[R1]acl 2000
[R1-acl-basic-2000]rul 1 permit source any
[R1-acl-basic-2000]quit
[R1]interface Serial 4/0/0
[R1-Serial4/0/0]nat outbound 2000
R2:

[R2]acl 2000
[R2-acl-basic-2000]rul 1 permit source any
[R2-acl-basic-2000]quit
[R2]interface Serial 4/0/0
[R2-Serial4/0/0]nat outbound 2000
R3:

[R3]acl 2000
[R3-acl-basic-2000]rul 1 permit source any
[R3-acl-basic-2000]quit
[R3]interface Serial 4/0/0
[R3-Serial4/0/0]nat outbound 2000
R4:

[R4]acl 2000
[R4-acl-basic-2000]rul 1 permit source any
[R4-acl-basic-2000]quit
[R4]interface GigabitEthernet 0/0/0
[R4-GigabitEthernet0/0/0]nat outbound 2000
6、R1和R5间使用PPP的PAP认证,R5为主认证方:
主认证方R5:
[R5]aaa
[R5-aaa]local-user chen password cipher 123456
[R5-aaa]local-user chen service-type ppp
[R5-aaa]quit
[R5]interface Serial 4/0/1
[R5-Serial4/0/1]ppp authentication-mode pap
被认证方R1 :
[R1]interface Serial 4/0/0
[R1-Serial4/0/0]ppp pap local-user chen password cipher 123456
7、R2于R5之间使用PPP的chap认证,R5为主认证方:
主认证方R5:
[R5]aaa
[R5-aaa]local-user chen password cipher 123456
[R5-aaa]local-user chen service-type ppp
[R5-aaa]quit
[R5]interface Serial 3/0/1
[R5-Serial3/0/1]ppp authentication-mode chap
被认证方R2:
[R2]interface Serial 4/0/0
[R2-Serial4/0/0]ppp chap user chen
[R2-Serial4/0/0]ppp chap password cipher 123456
8、R3于R5之间使用HSDLXC封装:
R3:
[r3]interface Serial 4/0/0
[R3-Serial4/0/0]link-protocol hdlc
Warning:The encapsulation protocol of the link will be changed.Continue?[Y/N]:y
R5 :
[r5]interface Serial 4/0/0
[R5-Serial4/0/0]link-protocol hdlc
Warning:The encapsulation protocol of the link will be changed.Continue?[Y/N]:y
9、R1/R2/R3构建一个MGR环境,R1为中心站点,R1、R4间为点到点的GRE:
(1)MGRE环境的搭建:
R1:
[R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/0]ip address 10.1.1.1 24
[R1-Tunnel0/0/0]tunnel-protocol gre p2mp
[R1-Tunnel0/0/0]source 15.1.1.1
[R1-Tunnel0/0/0]nhrp network-id 100

R2:
[R2]interface Tunnel 0/0/0
[R2-Tunnel0/0/0]ip address 10.1.1.2 24
[R2-Tunnel0/0/0]tunnel-protocol gre p2mp
[R2-Tunnel0/0/0]source Serial 4/0/0
[R2-Tunnel0/0/0]nhrp entry 10.1.1.1 15.1.1.1 register

(2)GRE环境的搭建:
R1:
[R1]interface Tunnel 0/0/1
[R1-Tunnel0/0/1]ip address 20.1.1.1 24
[R1-Tunnel0/0/1]tunnel-protocol gre
[R1-Tunnel0/0/1]source 15.1.1.1
[R1-Tunnel0/0/1]destination 45.1.1.1

R4:
[R4]interface Tunnel 0/0/1
[R4-Tunnel0/0/1]ip address 20.1.1.2 24
[R4-Tunnel0/0/1]tunnel-protocol gre
[R4-Tunnel0/0/1]source 45.1.1.1
[R4-Tunnel0/0/1]destination 15.1.1.1

10、整个私有网络基于RIP全网可达:
R1 :
[R1]rip 1
[R1-rip-1]version 2
[R1-rip-1]network 192.168.1.0
[R1-rip-1]network 10.0.0.0
[R1-rip-1]network 20.0.0.0
[R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/0]nhrp entry multicast dynamic
[R1-Tunnel0/0/0]undo rip split-horizon

R2 :
  1. [R2]rip 1

  2. [R2-rip-1]version 2

  3. [R2-rip-1]network 192.168.2.0

  4. [R2-rip-1]network 10.0.0.0

 R3:
  1. [R3]rip 1

  2. [R3-rip-1]version 2

  3. [R3-rip-1]network 192.168.3.0

  4. [R3-rip-1]network 10.0.0.0

R4 :
  1. [R4]rip 1

  2. [R4-rip-1]version 2

  3. [R4-rip-1]network 192.168.4.0

  4. [R4-rip-1]network 20.0.0.0+

11、所有pc设置私有IP为源IP,可以访问R5环回,达到全网可达。
PC1:

PC2:

PC:3PC4:PC5:

12、测试全网可达 
R1 ping R5环回 5.5.5.5:

R2 ping R5环回 5.5.5.5 :

 R3 ping R5环回 5.5.5.5 :

R4 ping R5环回 5.5.5.5 :

全网可达 

  • 42
    点赞
  • 27
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值