题目1002:Grading

题目描述:

    Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other, a judge is invited to make the final decision. Now you are asked to write a program to help this process.
    For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:
    • A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem's grade will be the average of G1 and G2.
    • If the difference exceeds T, the 3rd expert will give G3.
    • If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem's grade will be the average of G3 and the closest grade.
    • If G3 is within the tolerance with both G1 and G2, then this problem's grade will be the maximum of the three grades.
    • If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

输入:

    Each input file may contain more than one test case.
    Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

输出:

    For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

样例输入:
20 2 15 13 10 18
样例输出:
14.0
#include<iostream>
#include<cstdio>

using namespace std;
double abs(double a,double b){
	if(a-b<0){
		return b-a;	
	}else{
		return a-b;
	}
}
int main(){	
	int P=0,T=0;
	while(scanf("%d",&P)!=EOF){
		cin>>T;
		double temp=0;
		double G1=0,G2=0,G3=0,GJ=0;
		cin>>G1>>G2>>G3>>GJ;
		if((G1-G2)<=T&&(G1-G2)>=-T){
			temp=(G1+G2)/2;
			printf("%.1lf\n",temp);
			//cout<<temp<<endl;
			continue;
		}
		if((G1-G3)<=T&&(G1-G3)>=-T&&(G3-G2)<=T&&(G3-G2)>=-T){
			int max=G1;
			if(max<G2) max=G2;
			if(max<G3) max=G3;
			printf("%.1lf\n",max);
		//	cout<<max<<endl;
		}		
		else if(((G1-G3)<=T&&(G1-G3)>=-T)||((G3-G2)<=T&&(G3-G2)>=-T)){
			if(abs(G1,G3)<abs(G2,G3)){
			 	temp=(G1+G3)/2;
			}else{
				temp=(G2+G3)/2;
			}
			printf("%.1lf\n",temp);
			//cout<<temp<<endl;
		}else{
			printf("%.1lf\n",GJ);请保留两位小数,如果是double,则用lf,如果是float,则用f
		//	cout<<GJ<<endl;
		}
	}
	return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值