HDU 1001

8 篇文章 0 订阅
<h1 style="color: rgb(26, 92, 200);">Sum Problem</h1><strong><span style="color: green; font-family: Arial; font-size: 12px; font-weight: bold;">Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 278981    Accepted Submission(s): 69733
</span></strong>

<div align="left" class="panel_title">Problem Description</div><div class="panel_content">Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
</div><div class="panel_bottom"> </div>
<div align="left" class="panel_title">Input</div><div class="panel_content">The input will consist of a series of integers n, one integer per line.
</div><div class="panel_bottom"> </div>
<div align="left" class="panel_title">Output</div><div class="panel_content">For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
</div><div class="panel_bottom"> </div>
<div align="left" class="panel_title">Sample Input</div><div class="panel_content"><pre><div style="font-family: Courier New,Courier,monospace;">1
100</div>
 

Sample Output
  
  
1 5050
 

#include<iostream>
using namespace std;
int main()
{
    int n;
    while(cin>>n)
    {
        long sum;
        sum = 0;
        for(int i = 1;i <=n;i ++)
            sum += i;
        cout << sum<<endl<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值