hdu 1001 Java大数简单方法

Sum Problem

Problem Description

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

Input

The input will consist of a series of integers n, one integer per line.

Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input

1
100

Sample Output

1

5050

题目很清楚:求1到n加起来的和;

ac代码

import java.util.*;
import java.math.*;

public class Main
{
    public static void main(String []args)
    {

         BigInteger [] b=new BigInteger [2];
         b[0]=BigInteger.ONE;
         b[1]=b[0].add(b[0]);
         Scanner cin=new Scanner(System.in);
         while(cin.hasNext())
         {
             BigInteger a=cin.nextBigInteger();
             a=a.multiply(a.add(b[0]));
             a=a.divide(b[1]);
             System.out.println(a);
             System.out.println();
         }

    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值