ZOJ 2748 Free Kick

135 篇文章 0 订阅
44 篇文章 0 订阅

In a soccer game, a direct free kick is also awarded to the opposing team if a player commits any of the offences.

A direct free kick in an immediate distance is a nightmare of the goalie. In order to help their goalkeeper, the defenders often choose to stand side by side between the free kick position and the goal, just like a straight "WALL". The goalkeeper expects the "WALL" can receive the shooting angle as much as possible. However, there are only 11 players in a team and some of them must pay attention to other offenders, so the defenders to make up the "WALL" are quite limited.

Let's make the problem easier on a simplified field map, shown as above. The two ends of the goal locate at (-a,0) and (a,0) respectively, and the free kick position is (x, y). Assuming the body width of every defender is always W, your task is to determine how many defenders are required at the least to make up the "WALL", so that they can help their goalie receive the shooting angle. According to FIFA's law, all the defender must keep a distance not less than D from the free kick position. The goalie will feel safe if the remaining shooting angle after the "WALL" is strictly less than A degree.


Input

The input consists of several test cases. In each case, there are six numbers in a single line, indicating aWxyD and A respectively.

Constraints:

  • aWDA are all positive numbers;
  • The distance between the goal and the free kick position is guaranteed greater than D;
  • The absolute value of each non-zero number is in the range [10-6, 106].

Proceed until the end of file.


Output

For each case, print an integral number on a single line, which denotes the minimal number of defenders is required to make the goalie safe. Note that this number may be greater than 11.


Sample Input

3.66 0.5 5 20.2 9.15 10
3.66 0.5 -5 -20.3 9.15 10

Sample Output

4
3

组成等腰时要的最少

#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    double a,w,x,y,d,A,pi,t;
    double b,c;
    double need;
    int n;
    pi=3.141592653;
    while(cin>>a>>w>>x>>y>>d>>A)
    {
        b=acos( (((x-a)*(x-a)+y*y)+((x+a)*(x+a)+y*y) - 4*a*a ) / ( 2*sqrt((x+a)*(x+a)+y*y)*sqrt((x-a)*(x-a)+y*y)) );
     ///  b=acos( (x*x-a*a+y*y) / ( sqrt((x+a)*(x+a)+y*y)*sqrt((x-a)*(x-a)+y*y) ) );
        need=b-A*pi/180; //到少要组成的角
        t=2 *d*tan(need/2)/w;
        if(t<=0)
        {
            cout<<0<<endl;
            continue;
        }
        if(t-int(t)!=0)
            n=int(t)+1;
        else
            n=int(t);
        cout<<n<<endl;
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值