Clever King

题目传送门:https://nanti.jisuanke.com/t/26172

Description:

In order to increase the happiness index of people’s lives, King Y has decided to develop the manufacturing industry vigorously. There are total n kinds of products that King can choose to produce, different products can improve the happiness index of poeple’s lives in different degrees, of course, the production of goods needs raw materials, different products need different ore or other products as raw materials. There are total m mines, and each mine can exploit different ore, Therefore, there are m types of ores, the cost of each mining for each mine is different, king Y want to maximize the income, the calculation method of income is:∑increased happiness index - ∑mining costs.
If you choose to exploit a mine, there will be an unlimited number of this kind of ore. What’s more, if you produce one product, the happiness index will definitely increase, no matter how many you produce.

Input:

The first line of the input has an integer T(1<=T<=50), which represents the number of test cases.
In each test case, the first line of the input contains two integers n(1<=n<=200)–the number of the products and m(1<=m<=200)–the number of mines. The second line contains n integers, val[i] indicates the happiness index that number i product can increase. The third line contains m integers, cost[i] indicates the mining cost of number i mine. The next n lines, each line describes the type of raw material needed for the number i product, in each line, the first two integers n1(1<=n1<=m)–the number of ores that this product needs, n2(1<=n2<=n)–the number of products that this product needs, the next n1 + n2 integers indicate the id of ore and product that this product needs. it guarantees that ∑n1+∑n2<=2000.

Output:

Each test case output an integer that indicates the maximum value ∑val[i]-∑cost[i].
忽略每行输出的末尾多余空格

样例输入

2
3 3
600 200 400
100 200 300
1 2 1 2 3
1 0 2
1 0 3
3 4
600 400 200
100 200 300 1000
2 1 1 2 3
1 0 1
1 0 1

样例输出

600
900

题目来源

2018 ACM-ICPC 中国大学生程序设计竞赛线上赛

学习……

最大权闭合子图
大佬POJ2987的题解
HiHoCoder 119周 最大权闭合子图

Code

#include <bits/stdc++.h>
using namespace std;
const int mn=5555;
const int mm=222222;
const int oo=1e9;
int node, st, sd, edge;
int ver[mm], flow[mm], Next[mm];
int head[mn], work[mn], dis[mn], q[mn], visit[mn];

inline void init(int _node, int _st, int _sd) {
    node=_node, st=_st, sd=_sd;
    for(int i=0; i<node; i++)
        head[i]=-1;
    edge=0;
}

void addedge(int u, int v, int c1, int c2) {
    ver[edge]=v, flow[edge]=c1, Next[edge]=head[u],head[u]=edge++;
    ver[edge]=u, flow[edge]=c2, Next[edge]=head[v],head[v]=edge++;
}
bool Dinic_bfs() {
    int i,u,v,l,r=0;
    for(i=0; i<node; ++i)dis[i]=-1;
    dis[q[r++]=st]=0;
    for(l=0; l<r; ++l)
        for(i=head[u=q[l]]; i>=0; i=Next[i])
            if(flow[i]&&dis[v=ver[i]]<0) {
                dis[q[r++]=v]=dis[u]+1;
                if(v==sd)return 1;
            }
    return 0;
}
long long Dinic_dfs(int u, int exp) {
    if(u==sd) return exp;
    for(int &i=work[u]; i>=0; i=Next[i]) {
        int v=ver[i], tp;
        if(flow[i]&&dis[v]==dis[u]+1&&(tp=Dinic_dfs(v,min(flow[i],exp)))>0) {
            flow[i]-=tp;
            flow[i^1]+=tp;
            return tp;
        }
    }
    return 0;
}
long long Dinic_flow() {
    int i,delta;
    long long ret=0;
    while(Dinic_bfs()) {
        for(i=0; i<node; ++i)work[i]=head[i];
        while(delta=Dinic_dfs(st,oo))ret+=delta;
    }
    return ret;
}

void DFS(int u) {
    visit[u]=1;
    for(int i=head[u], v; i>=0; i=Next[i])
        if(flow[i]>0&&!visit[v=ver[i]]) DFS(v);
}
int T,n,m,w,v,u,n1,n2;
int main() {
    scanf("%d",&T);
    while(T--) {
        scanf("%d%d",&n,&m);
        init(n+m+2,0,n+m+1);
        long long sum=0;
        for(int i=1; i<=n; i++) {
            scanf("%d",&w);
            sum+=w;
            addedge(st,i,w,0);
        }
        for (int i=n+1;i<=n+m;++i) {
            scanf("%d",&w);
            addedge(i,sd,w,0);
        }

        for (int i=1;i<=n;++i) {
            scanf("%d%d",&n1,&n2);
            while (n1--) {
                scanf("%d",&u);
                addedge(i,u+n,oo,0);
            }
            while (n2--) {
                scanf("%d",&u);
                addedge(i,u,oo,0);
            }
        }

        long long maxflow=Dinic_flow();
        memset(visit,0,sizeof(visit));

        cout<<sum-maxflow<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值