Race to 1 Again LightOJ - 1038

Rimi learned a new thing about integers, which is - any positive integer greater than 1 can be divided by its divisors. So, he is now playing with this property. He selects a number N. And he calls this D.

In each turn he randomly chooses a divisor of D (1 to D). Then he divides D by the number to obtain new D. He repeats this procedure until D becomes 1. What is the expected number of moves required for N to become 1.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case begins with an integer N (1 ≤ N ≤ 105).

Output

For each case of input you have to print the case number and the expected value. Errors less than 10-6 will be ignored.

Sample Input

3

1

2

50

Sample Output

Case 1: 0

Case 2: 2.00

Case 3: 3.0333333333

Solution.

这题类似loj1027 A Dangerous Maze的,求解当前n的期望会用到之前求出来的m(m < < <script type="math/tex" id="MathJax-Element-146"><</script>n)的期望,以及n的期望(当除数是1时),整理一下,解一元一次方程即可。
预处理 105 10 5 个数,复杂度是 nn n n 的。

Code

#include <bits/stdc++.h>

using namespace std;
const int MX = 100010;
int T, n, j;
double d[MX];

int main() {
//    freopen("../in","r",stdin);
    d[1] = 0;
    d[2] = 2;
    for (int i = 3; i <= 100000; ++i) {
        n = 0;
        for (j = 2; j * j < i; ++j) {
            if (i % j == 0) {
                n += 2;
                d[i] += d[j];
                d[i] += d[i / j];
            }
        }
        if (j*j==i) {
            n++;
            d[i]+=d[j];
        }
        d[i] += n + 2;
        d[i] /= n + 1;
    }
    scanf("%d", &T);
    for (int I = 1; I <= T; ++I) {
        printf("Case %d: ", I);
        scanf("%d", &n);
        printf("%.7f\n", d[n]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值