D - Just another Robbery LightOJ - 1079

As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated risk, and grab as much money as possible. But his friends - Hermione and Ron have decided upon a tolerable probability P of getting caught. They feel that he is safe enough if the banks he robs together give a probability less than P.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a real number P, the probability Harry needs to be below, and an integer N (0 < N ≤ 100), the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj (0 < Mj ≤ 100) and a real number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj. A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Output

For each case, print the case number and the maximum number of millions he can expect to get while the probability of getting caught is less than P.

Sample Input

3

0.04 3

1 0.02

2 0.03

3 0.05

0.06 3

2 0.03

2 0.03

3 0.05

0.10 3

1 0.03

2 0.02

3 0.05

Sample Output

Case 1: 2

Case 2: 4

Case 3: 6

Note

For the first case, if he wants to rob bank 1 and 2, then the probability of getting caught is 0.02 + (1 - 0.02) * .03 = 0.0494 which is greater than the given probability (0.04). That's why he has only option, just to rob rank 2.

Solution

被抓概率=1-逃跑概率

n个逃跑概率可以直接相乘得到总的逃跑概率

接下来交给01背包。100家银行,每家的价值<=100,因此我们能够以取得的总价值为背包容量,以逃跑概率为相应的价值。最后寻找答案的时候,从sumVal向0枚举,遇到的第一个>=1-P(被抓概率上限)的价值即为答案。

#include<bits/stdc++.h>

#define ll long long
#define L(u) u<<1
#define R(u) u<<1|1
using namespace std;
const int MX = 101;
int T, n, sumVal;
int val[MX];
double f[MX*MX];
double p[MX],P;

int main() {
//    freopen("../in", "r", stdin);
    scanf("%d",&T);
    for (int I=1;I<=T;++I) {
        printf("Case %d: ",I);
        scanf("%lf%d",&P,&n);
        P = 1 - P;
        sumVal = 0;
        for (int i=0;i<n;++i) {
            scanf("%d%lf",&val[i],&p[i]);
            p[i]=1-p[i];
            sumVal+=val[i];
        }
        memset(f,0,sizeof(f));
        f[0] = 1;
        for (int i=0;i<n;++i)
            for (int j=sumVal;j>=val[i];--j)
                f[j]=max(f[j],f[j-val[i]]*p[i]);
        for (int i=sumVal;i>=0;--i) {
            if (f[i]>=P) {
                printf("%d\n",i);
                break;
            }
        }
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是一个基本的代码示例,可以从数据集中提取光流图并应用于i3d网络: ```python import os import cv2 import numpy as np # 定义数据集文件夹和光流图文件夹路径 data_dir = "C:/crime" frames_dir = "C:/crime/crime_frames" # 定义光流图的分辨率和时间跨度 flow_resolution = (224, 224) flow_timestep = 1 # 循环遍历数据集中的每个类别 for class_name in os.listdir(data_dir): # 获取当前类别的文件夹路径 class_dir = os.path.join(data_dir, class_name) # 循环遍历当前类别中的每个视频 for video_name in os.listdir(class_dir): # 获取当前视频的文件夹路径 video_dir = os.path.join(class_dir, video_name) # 获取当前视频的光流图文件夹路径 flow_dir = os.path.join(frames_dir, class_name, video_name) # 如果光流图文件夹不存在,则创建它 if not os.path.exists(flow_dir): os.makedirs(flow_dir) # 读取当前视频中的每一帧 frames = [] for frame_name in os.listdir(video_dir): frame_path = os.path.join(video_dir, frame_name) frame = cv2.imread(frame_path) frames.append(frame) # 将帧转换为灰度图像 gray_frames = [cv2.cvtColor(frame, cv2.COLOR_BGR2GRAY) for frame in frames] # 计算光流图 flows = [] for i in range(0, len(gray_frames) - 1, flow_timestep): prev_gray = gray_frames[i] curr_gray = gray_frames[i + flow_timestep] flow = cv2.calcOpticalFlowFarneback(prev_gray, curr_gray, None, 0.5, 3, 15, 3, 5, 1.2, 0) flow = cv2.resize(flow, flow_resolution) flows.append(flow) # 将光流图保存到文件夹中 for i, flow in enumerate(flows): flow_path = os.path.join(flow_dir, "{:05d}.jpg".format(i)) np.save(flow_path, flow) ``` 代码解释: 1. 首先定义了数据集文件夹和光流图文件夹的路径。 2. 然后循环遍历数据集中的每个类别,每个类别都有一个文件夹名字。 3. 对于每个类别,循环遍历其中的每个视频,每个视频也有一个文件夹名字。 4. 对于每个视频,获取它的光流图文件夹路径,如果该文件夹不存在,则创建它。 5. 读取每个视频的所有帧,并将它们转换为灰度图像。 6. 计算光流图,使用cv2.calcOpticalFlowFarneback函数计算两帧之间的光流。 7. 将光流图保存到光流图文件夹中,以.npy格式保存。 最后,我们可以将生成的光流图应用于i3d网络进行分类任务。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值