HDU 4679 Terrorist’s destroy

Terrorist’s destroy

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 621    Accepted Submission(s): 184


Problem Description
There is a city which is built like a tree.A terrorist wants to destroy the city's roads. But now he is alone, he can only destroy one road, then the city will be divided into two cities. Impression of the city is a number defined as the distance between the farthest two houses (As it relates to the fare).When the terrorist destroyed a road, he needs to spend some energy, assuming that the number is a.At the same time,he will get a number b which is maximum of the Impression of two cities. The terrorist wants to know which road to destroy so that the product of a and b will be minimized.You should find the road's id.
Note that the length of each road is one.
 

Input
The first line contains integer T(1<=T<=20), denote the number of the test cases.
For each test cases,the first line contains a integer n(1 < n <= 100000);denote the number of the houses;
Each of the following (n-1) lines contains third integers u,v,w, indicating there is a road between house u and houses v,and will cost terrorist w energy to destroy it.The id of these road is number from 1 to n-1.(1<=u<=n , 1<=v<=n , 1<=w<=10000)
 

Output
For each test case, output the case number first,and then output the id of the road which the terrorist should destroy.If the answer is not unique,output the smallest id.
 

Sample Input
  
  
2 5 4 5 1 1 5 1 2 1 1 3 5 1 5 1 4 1 1 3 1 5 1 1 2 5 1
 

Sample Output
  
  
Case #1: 2 Case #2: 3
 

Source
 

Recommend
zhuyuanchen520
 
各种bfs都是为了最后的枚举边,在枚举边的时候如果边不在直径上,就w*直径,在直径上借助先前预处理出来的当断裂时两城市的最大距离(dp加速)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#define N 100100
#define INF 0x7ffffff
using namespace std;
struct infor
{
    int u,v,w,next,pt;
}a[2*N],Map[2*N];
int b[N],level[N],dep[N],pre[N],temp[N];
int dp1[N],dp2[N],sum[N],Top,n;
bool check[N],bir[N],inque[N];
int main()
{
    //freopen("data.in","r",stdin);
    void addeage(int x,int y,int pos);
    void ra_bfs(int &s,int &e);
    void DP(int *p);
    int t,tem=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(b,-1,sizeof(b));
        Top=1;
        for(int i=1;i<=n-1;i++)
        {
            int x,y,w;
            scanf("%d %d %d",&x,&y,&w);
            Map[i].u = x;
            Map[i].v = y;
            Map[i].w = w;
            addeage(x,y,i);
            addeage(y,x,i);
        }
        //求直径
        int s=1,e;
        ra_bfs(s,e); //s->e;
        ra_bfs(e,s);//e->s
        Top=0;
        int point=s;
        memset(check,false,sizeof(check));
        while(true)
        {
            dep[Top++] = point;
            check[point] = true;
            int k = pre[point];
            bir[a[k].pt] = false;
            if(!pre[point])
            {
                break;
            }
            point=a[k].u;
        }
        //倒求
        DP(dp2);
        //正求
        for(int i=0;i<=Top-1;i++)
        {
            temp[i] = dep[Top-1-i];
        }
        for(int i=0;i<=Top-1;i++)
        {
            dep[i] = temp[i];
        }
        DP(dp1);
        //枚举结果
        int Min=INF,key;
        for(int i=1;i<=n-1;i++)
        {
            int com;
            if(bir[i])
            {
                com = (Top-1)*(Map[i].w);
            }else
            {
                int x = Map[i].u;
                int y = Map[i].v;
                if(level[x]<level[y])
                {
                    com = max(dp1[x],dp2[y])*(Map[i].w);
                }else
                {
                    com = max(dp1[y],dp2[x])*(Map[i].w);
                }
            }
            if(com<Min)
            {
                Min = com;
                key = i;
            }
        }
        printf("Case #%d: %d\n",tem++,key);
    }
    return 0;
}
void addeage(int x,int y,int pos)
{
    a[Top].u = x;
    a[Top].v = y;
    a[Top].next = b[x];
    a[Top].pt = pos;
    b[x] = Top++;
    bir[pos] = true;
}
void ra_bfs(int &s,int &e)
{
    level[s] = 1;
    queue<int>que;
    memset(inque,false,sizeof(inque));
    que.push(s);
    inque[s] = true;
    pre[s] = 0;
    while(!que.empty())
    {
        int x = que.front();
        que.pop();
        for(int i=b[x];i!=-1;i=a[i].next)
        {
            int y = a[i].v;
            if(!inque[y])
            {
                pre[y] = i;
                level[y] = level[x]+1;
                que.push(y);
                inque[y] = true;
            }
        }
    }
    int Max=0;
    for(int i=1;i<=n;i++)
    {
        if(level[i]>Max)
        {
            Max = level[i];
            e = i;
        }
    }
}
void DP(int *p)
{
    p[dep[0]] = 0;
    memset(sum,0,sizeof(sum));
    for(int i=1;i<=Top-1;i++)
    {
        int x = dep[i];
        queue<int>que;
        que.push(x);
        sum[x] = 1;
        int Max = 1;
        while(!que.empty())
        {
            int x = que.front();
            que.pop();
            for(int i=b[x];i!=-1;i=a[i].next)
            {
                int y = a[i].v;
                if(sum[y]==0&&!check[y])
                {
                    sum[y] = sum[x] + 1;
                    Max = max(sum[y],Max);
                    que.push(y);
                }
            }
        }
        p[x] = max(p[dep[i-1]],i+Max-1);
    }
}

 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值