HDU 4268 Alice and Bob

Alice and Bob

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1424 Accepted Submission(s): 544


Problem Description
Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob's. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob's cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.

Input
The first line of the input is a number T (T <= 40) which means the number of test cases.
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice's card, then the following N lines means that of Bob's.

Output
For each test case, output an answer using one line which contains just one number.

Sample Input
  
  
2 2 1 2 3 4 2 3 4 5 3 2 3 5 7 6 8 4 1 2 5 3 4

Sample Output
  
  
1 2

Source

Recommend
liuyiding
      以前真的很烦stl,能自己写就是自己写,通过这题发现stl很短小精悍啊,通过这题了,学到了很多stl
   他那个贪心思想就是将全部的格子先按h进行排序,对于其中的一个alice的,前边的bob的格子的h肯定都符合要求,然后再在里面找一个满足要求最大w。
#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <string>
#include <math.h>
#include <set>
using namespace std;
struct num
{
    int h,w,flag;
}a[1000000];
int cmp(const void *e,const void *f)
{
    struct num *p1=(struct num *)e;
    struct num *p2=(struct num *)f;
    if(p1->h!=p2->h)
    {
        return (p1->h - p2->h);
    }
    if(p1->w!=p2->w)
    {
        return (p1->w - p2->w);
    }
    return p2->flag - p1->flag;
}
int main()
{
    int i,j,n,m,s,t,res;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<=n-1;i++)
        {
            scanf("%d %d",&a[i].h,&a[i].w);
            a[i].flag=0;
        }
        for(i=0;i<=n-1;i++)
        {
            scanf("%d %d",&a[n+i].h,&a[n+i].w);
            a[n+i].flag=1;
        }
        qsort(a,2*n,sizeof(a[0]),cmp);
        multiset<int> s1;
        s1.clear();
        for(i=0,res=0;i<=2*n-1;i++)
        {
            if(a[i].flag)
            {
                s1.insert(a[i].w);
            }else
            {
                if(!s1.empty()&& *s1.begin()<=a[i].w)
                {
                    multiset<int>::iterator it=s1.upper_bound(a[i].w);
                    it--;
                    s1.erase(it);
                    res+=1;
                }
            }
        }
        printf("%d\n",res);
    }
    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值