杭电1016

 

                    Prime Ring Problem

                                              Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                    Total Submission(s): 11147    Accepted Submission(s): 5047


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
 
 这题我用的回溯法做的,敬请指教:
#include <stdio.h>
int a[51],b[21],c[21],n;
int main()
{
    void f(int x);
    int i,j,y;
      for(i=1;i<=50;i++)
        {
            a[i]=1;
        }
        for(i=2;i<=50;i++)
        {
            if(a[i]==1)
            {
               for(j=2;i*j<=50;j++)
                {
                    a[i*j]=0;
                }
            }
        }
        y=1;
    while(scanf("%d",&n)!=EOF)
    {    
        for(i=1;i<=20;i++)
        {
            b[i]=1;
        }
        printf("Case %d:\n",y);
        f(2);
        printf("\n");
        y++;
    }
    return 0;
}
void f(int x)
{
    int i;
    int j;
    c[1]=1;
    b[1]=0;
    for(i=2;i<=n;i++)
    {
        if(b[i]==1&&a[c[x-1]+i]==1)
        {
            if(x==n&&a[c[1]+i]==1||x!=n)
            {
                c[x]=i;
                b[i]=0;
                if(x<n)
                {
                    f(x+1);
                }else
                {
                    for(j=1;j<=n;j++)
                    {
                        if(j==1)
                        {
                            printf("%d",c[j]);
                        }else
                        {
                            printf(" %d",c[j]);
                        }
                    }
                    printf("\n");
                }
                b[i]=1;
            }
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值