UVa 10305 - Ordering Tasks

Problem F

Ordering Tasks

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and m. nis the number of tasks (numbered from 1to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.

Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4
1 2
2 3
1 3
1 5
0 0

Sample Output

1 4 2 5 3

(The Joint Effort Contest, Problem setter: Rodrigo Malta Schmidt)

拓扑排序吧 GO

#include <iostream>
#include <string.h>
#include <stdlib.h>
using namespace std;
class num
{
    public:
    int i;
    int sum;
}a[1000];
int cmp(const void *b,const void *c)
{
    num *p1=(num *)b; num *p2=(num *)c;
    if(p1->sum!=p2->sum)
    {
        return p1->sum-p2->sum;
    }else
    {
        return p1->i-p2->i;
    }
}
int main()
{
    int i,j,n,m,s,t;
    int x,y;
    while(cin>>n>>m)
    {
        if(!n&&!m)
        {
            break;
        }
        for(i=1;i<=n;i++)
        {
            a[i].i=i;
            a[i].sum=0;
        }
        for(i=0;i<=m-1;i++)
        {
            cin>>x>>y;
            a[y].sum++;
        }
        qsort(a+1,n,sizeof(a[0]),cmp);
        for(i=1;i<=n;i++)
        {
            if(i==1)
            {
                cout<<a[i].i;
            }else
            {
                cout<<' '<<a[i].i;
            }
        }
        cout<<endl;
    }
    return 0;
}


 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值