拓扑排序简单题

UVA10305
John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is
only possible if other tasks have already been executed.
Input
The input will consist of several instances of the problem. Each instance begins with a line containing
two integers, 1 ≤ n ≤ 100 and m. n is the number of tasks (numbered from 1 to n) and m is the
number of direct precedence relations between tasks. After this, there will be m lines with two integers
i and j, representing the fact that task i must be executed before task j.
An instance with n = m = 0 will finish the input.
Output
For each instance, print a line with n integers representing the tasks in a possible order of execution.
Sample Input
5 4
1 2
2 3
1 3
1 5
0 0
Sample Output
1 4 2 5 3
分析:就是输入n,m以0,0结束,接下来m行都是两个数i,j,代表i在j前面输出,让你输出可能的结果
要注意是可能的结果,应为这个wa了几次,代码就是普通的拓扑排序。

#include<iostream>
#include<string.h>
#define maxn 1000
int cs[maxn],a[maxn][maxn];
int n,m;
void topsort()
{
    for(int i = 1;i <= n; i++)
        for(int j = 1;j <= n; j++)
        {
            if(cs[j] == 0)
            {
                cs[j]--;
                printf("%d",j);
                if(i != n) printf(" ");
                else printf("\n");
                for(int k = 1;k <= n; k++)
                {
                    if(a[j][k])
                        cs[k]--;
                }
                break;
            }
        }
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(cs,0,sizeof(cs));
        memset(a,0,sizeof(a));
        int x,y;
        for(int i = 1; i <= m; i++){
            scanf("%d%d",&x,&y);
            if(!a[x][y]){
                a[x][y] = 1;
                cs[y]++;
            }
        }
        topsort();
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值