POj 3259 Wormholes

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 21827 Accepted: 7772

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

考察点:
          最短路算法
#include <iostream>
#include <cstring>
using namespace std;
int statck[1000000];
int status[1000];
int sum[1000];
class num
{
    public:
    int end,val;
    int next;
}a[1000000];
int b[1000],res[1000];
int tag,n;
int INF=0x7fffffff;
int main()
{
    void deal(int k);
    int i,j,m,s,t,z,x,y,val;
    cin>>t;
    while(t--)
    {
        cin>>n>>m>>z;
        memset(b,-1,sizeof(b));
        j=0;
        for(i=0;i<=m-1;i++)
        {
            cin>>x>>y>>val;
            a[j].end=y;
            a[j].val=val;
            a[j].next=b[x];
            b[x]=j;
            j+=1;
            a[j].end=x;
            a[j].val=val;
            a[j].next=b[y];
            b[y]=j;
            j++;
        }
        for(i=0;i<=z-1;i++)
        {
            cin>>x>>y>>val;
            a[j].end=y;
            a[j].val=-1*val;
            a[j].next=b[x];
            b[x]=j;
            j++;
        }
        for(i=1;i<=n;i++)
        {
            memset(status,0,sizeof(status));
            memset(sum,0,sizeof(sum));
            tag=0;
            deal(i);
            if(tag==1)
            {
                cout<<"YES"<<endl;
                break;
            }
        }
        if(tag==0)
        {
            cout<<"NO"<<endl;
        }
    }
    return 0;
}
void deal(int k)
{
    int base,top;
    int i,j,x,xend;
    for(i=1;i<=n;i++)
    {
        res[i]=INF;
    }
    res[k]=0;
    base=top=0;
    statck[top++]=k;
    status[k]=1;
    sum[k]+=1;
    while(base<top)
    {
        x=statck[base];
        base++;
        status[x]=0;
        for(j=b[x];j!=-1;j=a[j].next)
        {
            if((res[x]+a[j].val)<res[a[j].end])
            {
                res[a[j].end]=(res[x]+a[j].val);
                if(res[k]<0)
                {
                    tag=1;
                    break;
                }
                if(status[a[j].end]==0)
                {
                    status[a[j].end]=1;
                    sum[a[j].end]+=1;
                    statck[top++]=a[j].end;
                    if(sum[a[j].end]>=n)
                    {
                        break;
                    }
                }  
            }
        }
        if(j!=-1)
        {
            break;
        }
    }

}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
未来社区的建设背景和需求分析指出,随着智能经济、大数据、人工智能、物联网、区块链、云计算等技术的发展,社区服务正朝着数字化、智能化转型。社区服务渠道由分散向统一融合转变,服务内容由通用庞杂向个性化、服务导向转变。未来社区将构建数字化生态,实现数据在线、组织在线、服务在线、产品智能和决策智能,赋能企业创新,同时注重人才培养和科研平台建设。 规划设计方面,未来社区将基于居民需求,打造以服务为中心的社区管理模式。通过统一的服务平台和应用,实现服务内容的整合和优化,提供灵活多样的服务方式,如推送式、订阅式、热点式等。社区将构建数据与应用的良性循环,提高服务效率,同时注重生态优美、绿色低碳、社会和谐,以实现幸福民生和产业发展。 建设运营上,未来社区强调科学规划、以人为本,创新引领、重点突破,统筹推进、整体提升。通过实施院落+社团自治工程,转变政府职能,深化社区自治法制化、信息化,解决社区治理中的重点问题。目标是培养有活力的社会组织,提高社区居民参与度和满意度,实现社区治理服务的制度机制创新。 未来社区的数字化解决方案包括信息发布系统、服务系统和管理系统。信息发布系统涵盖公共服务类和社会化服务类信息,提供政策宣传、家政服务、健康医疗咨询等功能。服务系统功能需求包括办事指南、公共服务、社区工作参与互动等,旨在提高社区服务能力。管理系统功能需求则涉及院落管理、社团管理、社工队伍管理等,以实现社区治理的现代化。 最后,未来社区建设注重整合政府、社会组织、企业等多方资源,以提高社区服务的效率和质量。通过建立社区管理服务综合信息平台,提供社区公共服务、社区社会组织管理服务和社区便民服务,实现管理精简、高效、透明,服务快速、便捷。同时,通过培育和发展社区协会、社团等组织,激发社会化组织活力,为居民提供综合性的咨询和服务,促进社区的和谐发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值