POJ 3259 Wormholes

题目链接

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself 😃 .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2…M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2…M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1…F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

大致题意
第一行t,表示t组数据
每组数据第一行 n , m , w表示n个点,m条路,和w穿越的虫洞
接下来m行,每行三个数字表示两点和两点之间双向道来往所需要花费的时间
接下来w行,每行三个数字,表示从第一个数字的点到第二个数字点的单向道所需要消耗的时间
问从1点触发,是否可以一顿骚操作使得自己回到1点的时间比出发时还早?(按这个道理是不是可以一顿骚操作看看未来老婆?

具体思路
负权边来了,对于普通的最短路问题dijkstra足以应付,但只限于正权边,当出现负权时候,点少可以直接暴力floyd,复杂度是O(n^3),当点多,边少时候就需要使用spfa来优化,spfa其实也只是dijkstra的变形,无非就是加个数组标记各个点进入队列的次数,当超过n的时候说明出现负环,也是根据这个负环来判断各个点最后会变成一个怎么样的状态,一般只要有个点出现负自环,一顿骚操作就是无限小,出现正自环就是无限大,以此来解决问题,当此点出现无限大,与其相连的点也就可以通过这个无限大的点随之无限大

#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
struct node
{
    int to,cost;
};
int t,n,m,w;
vector<node>line[505];
int dis[505],flag[505],ans[505],num[505];
bool spfa()
{
    queue<int>dui;
    dis[1]=0;
    flag[1]=1;
    dui.push(1);
    num[1]++;
    while (!dui.empty())
    {
        int now=dui.front();
        dui.pop();
        flag[now]=0;
        for (int i=0;i<line[now].size();i++)
        {
            if (dis[now]+line[now][i].cost<dis[line[now][i].to])
            {
                dis[line[now][i].to]=dis[now]+line[now][i].cost;
                if (flag[line[now][i].to]==0)
                {
                    flag[line[now][i].to]=1;
                    dui.push(line[now][i].to);
                    num[line[now][i].to]++;
                    if (num[line[now][i].to]>n)
                        return true;
                }
            }
        }
    }
    return false;
}
int main()
{
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d %d %d",&n,&m,&w);
        for (int i=1;i<=n;i++)
        {
            flag[i]=0;
            dis[i]=0x7fffffff;
            line[i].clear();
            num[i]=0;
        }
        for (int i=0;i<m;i++)
        {
            int flags=0;
            int from,to,cost;
            scanf("%d %d %d",&from,&to,&cost);
            node now;
            now.to=to;
            now.cost=cost;
            line[from].push_back(now);
            now.to=from;
            line[to].push_back(now);
        }
        for (int i=0;i<w;i++)
        {
            int from,to,cost;
            scanf("%d %d %d",&from,&to,&cost);
            node now;
            now.to=to;
            now.cost=-1*cost;
            line[from].push_back(now);
        }
        if (spfa())
        {
            printf("YES\n");
        }else
        {
            printf("NO\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值