POJ 2406 Power Strings

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 26177 Accepted: 10976

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

   其实这道题目的思路来自POJ 1961,建议先做做1961,做完之后这道题目就会很容易的解决了
/***************************************************************
 > File Name: E:\我的程序\C语言\power.c
 > Author: SDUT_GYX
 > Mail: 2272902662@qq.com
 > Created Time: 2013/5/9 10:14:47
 **************************************************************/

#include<stdio.h>
#include <string.h>
#include <math.h>
char s1[1100000];
int next[1100000],dp[1100000];
int main()
{
	void get_next(int l);
	int i,j,n,m,s,t,l;
	while(gets(s1))
	{
        if(strcmp(s1,".")==0)
		{
			break;
		}
		l=strlen(s1);
		get_next(l);
		dp[0]=0;
		for(i=2;i<=l;i++)
		{
		   n=next[i];
		   if(n+n==i)
		   {
			   dp[i-1]=n;
		   }else if(n+n<i)
		   {
			   dp[i-1]=0;
		   }else
		   {
			   dp[i-1]=dp[n-1];
		   }
		}
		if(dp[l-1]==0)
		{
			printf("1\n");
		}else
		{
			printf("%d\n",l/dp[l-1]);
		}
	}
	return 0;
}
void get_next(int l)
{
	int i,j;
	next[0]=-1;
	next[1]=0;
	for(i=2,j=0;i<=l;)
	{
		if(j==-1||s1[i-1]==s1[j])
		{
			i++;j++;
			next[i-1]=j;
		}else
		{
			j=next[j];
		}
	}
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值