ACM-ICPC 2018 徐州赛区网络预赛 H. Ryuji doesn't want to study

Ryuji is not a good student, and he doesn't want to study. But there are n books he should learn, each book has its knowledge a[i]a[i]a[i].

Unfortunately, the longer he learns, the fewer he gets.

That means, if he reads books from lll to rrr, he will get a[l]×L+a[l+1]×(L−1)+⋯+a[r−1]×2+a[r]a[l] \times L + a[l+1] \times (L-1) + \cdots + a[r-1] \times 2 + a[r]a[l]×L+a[l+1]×(L−1)+⋯+a[r−1]×2+a[r] (LLL is the length of [ lll, rrr ] that equals to r−l+1r - l + 1r−l+1).

Now Ryuji has qqq questions, you should answer him:

111. If the question type is 111, you should answer how much knowledge he will get after he reads books [ lll, rrr ].

222. If the question type is 222, Ryuji will change the ith book's knowledge to a new value.

Input

First line contains two integers nnn and qqq (nnn, q≤100000q \le 100000q≤100000).

The next line contains n integers represent a[i](a[i]≤1e9)a[i]( a[i] \le 1e9)a[i](a[i]≤1e9) .

Then in next qqq line each line contains three integers aaa, bbb, ccc, if a=1a = 1a=1, it means question type is 111, and bbb, ccc represents [ lll , rrr ]. if a=2a = 2a=2 , it means question type is 222 , and bbb, ccc means Ryuji changes the bth book' knowledge to ccc

Output

For each question, output one line with one integer represent the answer.

样例输入复制

5 3
1 2 3 4 5
1 1 3
2 5 0
1 4 5

样例输出复制

10
8

题目来源

ACM-ICPC 2018 徐州赛区网络预赛

题目大意:n个数,q次操作,每次操作分两种,当ope=1时查询区间[l,r]的和=a[l]*(r-l+1)+a[l+1]*(r-l)...a[r];当ope==2时,数组在位置i的数字变成了新的数字。

分析:

用两个树状数组来维护,一个维护a[1]+a[2]+...+a[n]的和,另一个来维护n*a[1]+(n-1)*a[2]+...a[n]的和。

最终查询区间的结果就是第二个树状数组的区间和-(n-r)*第一个树状数组的区间和。(拿一个查询区间画一下就可以知道了)

代码:

#include <bits/stdc++.h>
using namespace std;
#define lowbit(x) x&(-x)
const int maxn=1e5+10;
typedef long long ll;
ll n,q;
ll a[maxn];
void add(ll x,ll val,ll ans[])        ///更新
{
    while(x<=n)
    {
        ans[x]+=val;
        x+=lowbit(x);
    }
}
ll qury(ll x,ll ans[])               ///查询
{
    ll res=0;
    while(x>0)
    {
        res+=ans[x];
        x-=lowbit(x);
    }
    return res;
}
int main()
{
    while(~scanf("%d%d",&n,&q))
    {
        ll sum[maxn];
        ll sum1[maxn];
        memset(sum1,0,sizeof(sum1));
        memset(sum,0,sizeof(sum));
        for(ll i=1; i<=n; i++)
        {
            scanf("%lld",&a[i]);
            add(i,a[i],sum);
            add(i,(n-i+1)*a[i],sum1);
        }
        for(ll i=1; i<=q; i++)
        {
            ll ope;
            scanf("%lld",&ope);
            if(ope==1)
            {
                ll l,r;
                scanf("%lld%lld",&l,&r);
                printf("%lld\n",qury(r,sum1)-qury(l-1,sum1)-(n-r)*(qury(r,sum)-qury(l-1,sum)));
            }
            else
            {
                ll pos,val;
                scanf("%lld%lld",&pos,&val);
                add(pos,val-a[pos],sum);
                add(pos,(n-pos+1)*(val-a[pos]),sum1);
                a[pos]=val;
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
目标检测(Object Detection)是计算机视觉领域的一个核心问题,其主要任务是找出图像中所有感兴趣的目标(物体),并确定它们的类别和位置。以下是对目标检测的详细阐述: 一、基本概念 目标检测的任务是解决“在哪里?是什么?”的问题,即定位出图像中目标的位置并识别出目标的类别。由于各类物体具有不同的外观、形状和姿态,加上成像时光照、遮挡等因素的干扰,目标检测一直是计算机视觉领域最具挑战性的任务之一。 二、核心问题 目标检测涉及以下几个核心问题: 分类问题:判断图像中的目标属于哪个类别。 定位问题:确定目标在图像中的具体位置。 大小问题:目标可能具有不同的大小。 形状问题:目标可能具有不同的形状。 三、算法分类 基于深度学习的目标检测算法主要分为两大类: Two-stage算法:先进行区域生成(Region Proposal),生成有可能包含待检物体的预选框(Region Proposal),再通过卷积神经网络进行样本分类。常见的Two-stage算法包括R-CNN、Fast R-CNN、Faster R-CNN等。 One-stage算法:不用生成区域提议,直接在网络中提取特征来预测物体分类和位置。常见的One-stage算法包括YOLO系列(YOLOv1、YOLOv2、YOLOv3、YOLOv4、YOLOv5等)、SSD和RetinaNet等。 四、算法原理 以YOLO系列为例,YOLO将目标检测视为回归问题,将输入图像一次性划分为多个区域,直接在输出层预测边界框和类别概率。YOLO采用卷积网络来提取特征,使用全连接层来得到预测值。其网络结构通常包含多个卷积层和全连接层,通过卷积层提取图像特征,通过全连接层输出预测结果。 五、应用领域 目标检测技术已经广泛应用于各个领域,为人们的生活带来了极大的便利。以下是一些主要的应用领域: 安全监控:在商场、银行
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值