01变换 二维树状数组+区间更新,单点查询 poj 2155 Matrix

点击打开poj 2155

Matrix
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 21451 Accepted: 8017

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng

思路: 二维树状数组+区间更新,单点查询

分析:

点击打开查看论文  建议先看看这篇论文,比较好理解

1 题目给定两种操作,第一种是给定左上角和右下角的下标,把这个子矩形里面的0/1进行互换,第二种是问某个点的值

2 我们先看一维的情况


假设题目给定的是一个长度为n的一维数组

那么我们现在要把区间[i,j]里面的值进行0/1互换

首先我们先来看一个定理,假设一个数原先为0,那么它经过奇数次的变换为1,偶数次的变换为0。


所以我们可以这么这么想[i,j]区间要变换那么就是相当于区间里面的值加1,那么等价于i这个点加1,j+1这个点减一

那么我们要判断某个点x的值的时候只要求出[1,x]的和mod2即可,为什么呢?


1 如果更新的区间是x的左边,那么对于x来说没有影响

2 如果x在更新的区间里面,那么就相当于加1

3 如果x在区间的右边,那么由于i加1,j减1那么抵消了

综上所述,可知结论成立


3 那么推广到二维的情况也是一样的

假设要更新的矩形的左上角为(x1,y1),右下角为(x2,y2)


那么我们可以根据一维的思想推广到二维里面,那么我们就相当于(x1,y1)点加1,(x1,y2+1)点减1 ,(x2+1,y1)点减1 ,(x2+1 , y2+1)点加1


那么我们要求某个点(x,y)的值的时候也就相当于求点(1,1)到点(x,y)的矩形的值mod2


代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

const int MAXN = 1010;

int treeNum[MAXN][MAXN];

int lowbit(int x){
    return x&(-x);
}

long long getSum(int x , int y){
    long long sum = 0;
    for(int i = x ; i > 0 ; i -= lowbit(i))
        for(int j = y ; j > 0 ; j -= lowbit(j))
            sum += treeNum[i][j];
    return sum;
}

void add(int x , int y , int val){
    for(int i = x ; i < MAXN ; i += lowbit(i))
        for(int j = y ; j < MAXN ; j += lowbit(j))
            treeNum[i][j] += val;
}

void solve(int m){
    char ch;
    int x , y;
    int x1 , y1 , x2 , y2;
    memset(treeNum , 0 , sizeof(treeNum));
    while(m--){ 
        scanf("%c" , &ch); 
        if(ch == 'C'){
            scanf("%d%d" , &x1 , &y1);
            scanf("%d%d%*c" , &x2 , &y2);
            // update
            add(x1 , y1 , 1);
            add(x2+1 , y1 , -1);
            add(x1 , y2+1 , -1);
            add(x2+1 , y2+1 , 1);
        }
        else{
            scanf("%d%d%*c" , &x , &y);
            int ans = getSum(x , y);
            printf("%d\n" , ans%2);
        }
    }
}

int main(){
    int cas;
    int n , m;
    bool isFirst = true;
    scanf("%d" , &cas);
    while(cas){
        scanf("%d%d%*c" , &n , &m); 
        solve(m);
        if(--cas)
            puts("");
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值