二维树状数组 hdu 1892 See you~

点击打开hdu 1892

See you~

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 4199    Accepted Submission(s): 1323


Problem Description
Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now ~~>.<~~. I am very sorry, we could not advanced to the World Finals last year. 
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work is to tell me how many books are stayed in some rectangles. 
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position or bring in one book and put it on one position. 
 

Input
In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed. 
For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries. 
There are 4 kind of queries, sum, add, delete and move. 
For example: 
S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points. 
A x1 y1 n1 means I put n1 books on the position (x1,y1) 
D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them. 
M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them. 
Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100. 
 

Output
At the beginning of each case, output "Case X:" where X is the index of the test case, then followed by the "S" queries. 
For each "S" query, just print out the total number of books in that area. 
 

Sample Input
  
  
2 3 S 1 1 1 1 A 1 1 2 S 1 1 1 1 3 S 1 1 1 1 A 1 1 2 S 1 1 1 2
 

Sample Output
  
  
Case 1: 1 3 Case 2: 1 4
 

Author
Sempr|CrazyBird|hust07p43
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1166  1541  2492  1894  1394 
 

Statistic |  Submit |  Discuss |  Note

思路: 二维树状数组

分析:

1 题目给定4种操作:  S x1 y1 x2 y2 询问以(x1 , y1) - (x2 , y2)为对角线的矩形的面积,但是这个对角线不一定是正对角线。A x1 y1 n 把点(x1 , y1)加上n。D x1 y1 n点(x1 , y1)减去n如果不足n就全部删除即可。M x1 y1 x2 y2 n 把点(x1 , y1)点值中扣除n加到(x2 , y2),如果不过n则把(x1 , y1)值全部加到(x2 , y2)

2 简单的二维树状数组,但是注意在求矩形的面积的时候我们应该把矩形转化成正对角线的模式这样才不会错,在更显点的时候由于我们需要判断值的大小,所以我们需要一个数组保存每个点的值

3 初始化的时候由于每个点的值为1.那么树状数组treeNum[i][j] = lowbit(i)*lowbit(j)


代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

const int MAXN = 1e3+10;

int n;
int num[MAXN][MAXN];
int treeNum[MAXN][MAXN];

int lowbit(int x){
    return x&(-x);
}

int getSum(int x , int y){
    int sum = 0;
    for(int i = x ; i > 0 ; i -= lowbit(i)) 
        for(int j = y ; j > 0 ; j -= lowbit(j)) 
            sum += treeNum[i][j];
    return sum;
}

void add(int x , int y , int val){
    for(int i = x ; i < MAXN ; i += lowbit(i)) 
        for(int j = y ; j < MAXN ; j += lowbit(j)) 
            treeNum[i][j] += val;
}

void init(){
    memset(treeNum , 0 , sizeof(treeNum));
    for(int i = 1 ; i < MAXN ; i++){
       for(int j = 1 ; j < MAXN ; j++){
           num[i][j] = 1;
           treeNum[i][j] = lowbit(i)*lowbit(j);
       }
    }
}

void solve(){
    init();
    char c;
    int x , y , val;
    int x1 , y1 , x2 , y2;
    int x3 , y3 , x4 , y4;
    while(n--){
        scanf("%c" , &c); 
        if(c == 'S'){
            scanf("%d%d" , &x1 , &y1); 
            scanf("%d%d%*c" , &x2 , &y2); 
            x1++ , y1++ , x2++ , y2++;

            x3 = min(x1 , x2) , y3 = min(y1 , y2);
            x4 = max(x1 , x2) , y4 = max(y1 , y2);
            int ans = getSum(x4 , y4); 
            ans -= getSum(x3-1 , y4);
            ans -= getSum(x4 , y3-1);
            ans += getSum(x3-1 , y3-1);
            printf("%d\n" , ans);
        }
        else if(c == 'A'){
            scanf("%d%d%d%*c" , &x , &y , &val); 
            x++ , y++;
            num[x][y] += val;
            add(x , y , val);
        }
        else if(c == 'D'){
            scanf("%d%d%d%*c" , &x , &y , &val); 
            x++ , y++;
            val = min(num[x][y] , val);
            num[x][y] -= val;
            add(x , y , -val);
        }
        else{
            scanf("%d%d" , &x1 , &y1); 
            scanf("%d%d%d%*c" , &x2 , &y2 , &val); 
            x1++ , y1++ , x2++ , y2++;
            val = min(num[x1][y1] , val);
            num[x1][y1] -= val;
            num[x2][y2] += val;
            add(x1 , y1 , -val);
            add(x2 , y2 , val);
        }
    }
}

int main(){
    int cas;
    int Case = 1;
    scanf("%d" , &cas);
    while(cas--){
        scanf("%d%*c" , &n);     
        printf("Case %d:\n" , Case++);
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值