DFS-The partial sum problem

The partial sum problem

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
One day,Tom’s girlfriend give him an array A which contains N integers and asked him:Can you choose some integers from the N integers and the sum of them is equal to K. 
输入
There are multiple test cases.
Each test case contains three lines.The first line is an integer N(1≤N≤20),represents the array contains N integers. The second line contains N integers,the ith integer represents A[i](-10^8≤A[i]≤10^8).The third line contains an integer K(-10^8≤K≤10^8).
输出
If Tom can choose some integers from the array and their them is K,printf ”Of course,I can!”; other printf ”Sorry,I can’t!”.
样例输入
4
1 2 4 7
13
4
1 2 4 7
15
样例输出
Of course,I can!
Sorry,I can't!

题目大意就是给你几个数,然后给你一个结果,这几个数组合加起来能不能等于这个数。

dfs水过,有大神剪枝,花了12MS,我花了884MS。。。


我的AC代码

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int a[22], book[22], N, K;
bool dfs(int step, int sum) {
	if (step == N) return sum == K;
	if (dfs(step+1, sum)) return true;
	if (dfs(step+1, sum+a[step])) return true;
	return false;
}
int main() {
	//freopen("in.txt", "r", stdin);
	while(~scanf("%d", &N)) {
		for (int i = 0; i < N; i++) scanf("%d", &a[i]);
		scanf("%d", &K);
		memset(book, 0, sizeof(book));
		if (dfs(0, 0)) puts("Of course,I can!");
		else puts("Sorry,I can't!");
	}
	
	return 0;
}

大神剪枝代码:


#include <iostream>
#include <algorithm>
using namespace std;

bool Handle();

int src[100],n,k;
int Max[100];
int Min[100];
bool Ok;
char* result[]= {"Sorry,I can't!","Of course,I can!"};
int main(){
while(Handle()){
//empty while
}
}

void DFS(int Step, int Sum);
void InitAry();
bool Handle(){
if(!(cin>>n)){
return false;
}
for(int i= 0; i< n; ++i){
cin>>src[i];
}
cin>>k;
Ok=false;
sort(src,src+n);
InitAry();
DFS(n-1,0);
cout<<result[Ok]<<endl;
return true;
}

void DFS(int Step, int Sum){
if(Ok){//we have found one
return;
}
if(Step==-1){
if(Sum==k){
Ok= true;
}
return;
}
if(Sum+Max[Step]< k){
return;
}
if(Sum+Min[Step]> k){
return;
}
DFS(Step-1,Sum);
DFS(Step-1,Sum+src[Step]);
}

void InitAry(){
Max[0]= max(0,src[0]);
Min[0]= min(0,src[0]);
for(int i= 1; i< n; ++i){
Max[i]= max(Max[i-1],Max[i-1]+src[i]);
Min[i]= min(Min[i-1],Min[i-1]+src[i]);
}
}        

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值