【二分匹配】zoj1654 Place the Robots

Place the Robots

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=654

Robert is a famous engineer. One day he was given a task by his boss. The background of the task was the following:

Given a map consisting of square blocks. There were three kinds of blocks: Wall, Grass, and Empty. His boss wanted to place as many robots as possible in the map. Each robot held a laser weapon which could shoot to four directions (north, east, south, west) simultaneously. A robot had to stay at the block where it was initially placed all the time and to keep firing all the time. The laser beams certainly could pass the grid of Grass, but could not pass the grid of Wall. A robot could only be placed in an Empty block. Surely the boss would not want to see one robot hurting another. In other words, two robots must not be placed in one line (horizontally or vertically) unless there is a Wall between them.

Now that you are such a smart programmer and one of Robert's best friends, He is asking you to help him solving this problem. That is, given the description of a map, compute the maximum number of robots that can be placed in the map.


Input


The first line contains an integer T (<= 11) which is the number of test cases. 

For each test case, the first line contains two integers m and n (1<= m, n <=50) which are the row and column sizes of the map. Then m lines follow, each contains n characters of '#', '*', or 'o' which represent Wall, Grass, and Empty, respectively.


Output

For each test case, first output the case number in one line, in the format: "Case :id" where id is the test case number, counting from 1. In the second line just output the maximum number of robots that can be placed in that map.


Sample Input

2
4 4
o***
*###
oo#o
***o
4 4
#ooo
o#oo
oo#o
***#


Sample Output

Case :1
3
Case :2
5


此题就是Fire Net的加强版。

不同的地方就是两个点相连的条件是有相交的空地(因为草地上不能放置机器人)。


//characters of '#', '*', or 'o' which represent Wall, Grass, and Empty, respectively.
#include<cstdio>
#include<cstring>
using namespace std;
#define MAX 1255
char map[MAX][MAX];
int colx[MAX][MAX],rowx[MAX][MAX];
bool path[MAX][MAX],visit[MAX];
int match[MAX];
bool SearchPath(int s,int m)
{
    for(int i=0; i<m; ++i)
    {
        if(path[s][i]&&!visit[i])
        {
            visit[i]=true;
            if(match[i]==-1||SearchPath(match[i],m))
            {
                match[i]=s;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    int n,m,row,col,cas;
    scanf("%d",&cas);
    for(int t=1; t<=cas; ++t)
    {
        scanf("%d%d",&n,&m);
        getchar();
        for(int i=0; i<n; ++i)
            gets(map[i]);
        row=col=0;
        memset(colx,-1,sizeof(colx));
        memset(rowx,-1,sizeof(rowx));
        for(int i=0; i<n; ++i)
        {
            for(int j=0; j<m; ++j)
            {
                if(map[i][j]!='#'&&rowx[i][j]==-1)
                {
                    for(int k=j; map[i][k]!='#'&&k<m; ++k)
                        rowx[i][k]=row;
                    ++row;
                }
                if(map[i][j]!='#'&&colx[i][j]==-1)
                {
                    for(int k=i; map[k][j]!='#'&&k<n; ++k)
                        colx[k][j]=col;
                    ++col;
                }
            }
        }
        memset(path,false,sizeof(path));
        for(int i=0; i<n; ++i)
            for(int j=0; j<m; ++j)
                if(map[i][j]=='o'&&rowx[i][j]!=-1&&colx[i][j]!=-1)
                    path[rowx[i][j]][colx[i][j]]=true;
        int summ=0;
        memset(match,-1,sizeof(match));
        for(int i=0; i<row; ++i)
        {
            memset(visit,false,sizeof(visit));
            if(SearchPath(i,col))
                summ++;
        }
        printf("Case :%d\n%d\n",t,summ);
    }
    return 0;
}


===下载后有不懂的可以私信我。==== 操作系统是计算机科学中的核心课程,它管理着计算机的硬件资源,为用户提供服务并协调各种软件运行。"王道操作系统课件 2024" 是一套全新的教学资料,旨在帮助学习者深入理解操作系统的工作原理和设计思想。这些课件包含了操作系统的一些关键主题,如操作系统概念、体系结构、进程管理、输入输出、文件系统以及存储设备等内容。 1. **操作系统概念与功能** (1.1_1_操作系统的概念、功能.pdf) 操作系统是计算机系统的核心,负责管理和控制硬件资源,提供用户接口和服务。其基本功能包括处理器管理、内存管理、设备管理、文件管理和作业调度等。这些功能确保了计算机系统的高效运行和资源的有效利用。 2. **操作系统体系结构** (1.4_2_操作系统体系结构(下).pdf) 操作系统的体系结构分为单体结构、微内核结构、客户-服务器结构、层状结构等。这些不同的架构设计各有优缺点,适应不同的应用场景和需求。例如,微内核结构强调最小化内核,提高系统稳定性和可扩展性。 3. **虚拟机** (1.6_虚拟机.pdf) 虚拟机技术允许在单一硬件平台上运行多个操作系统实例,通过模拟硬件环境实现隔离。虚拟机有全虚拟化和半虚拟化两种主要类型,分别适用于不同场景,如开发测试、云服务等。 4. **输入输出(I/O)管理** (5.1_5_输入输出应用程序接口和驱动程序接口.pdf) I/O管理涉及设备驱动程序、中断处理、DMA(Direct Memory Access)和I/O缓冲等。应用程序通过I/O接口与硬件交互,驱动程序则作为操作系统与硬件间的桥梁,使得硬件操作对用户透明。 5. **进程通信** (2.1_4_进程通信.pdf) 进程通信是多进程系统中协调和同步的重要手段,包括管道、消息队列、共享内存、信号量、套接字等多种机制。有效的进程通信可以提升系统效率,避免竞态条件和死锁等问题。 6. **文件系统全局结构** (4.3_2_文件系统的全局结构(布局).pdf) 文件系统负责组织和管理磁盘上的数据,包括目录结构、文件分配、文件的逻辑与物理结构等。了解文件系统的全局结构有助于优化数据存储和检索效率。 7. **文件保护** (4.1_9_文件保护.pdf) 文件保护涉及到权限管理、访问控制列表(ACL)、文件加密等,用于确保文件的安全性和完整性,防止非法访问和修改。 8. **固态硬盘(SSD)** (5.3_5_固态硬盘SSD.pdf) 固态硬盘使用闪存作为存储介质,相比传统硬盘,具有更快的读写速度、更低的延迟和更高的耐用性。SSD的特性对现代操作系统提出了新的存储管理挑战,如TRIM命令的使用和垃圾回收算法的设计。 这些课件覆盖了操作系统学习的核心知识点,通过深入研究,学生将能够全面理解操作系统的运作机制,并为解决实际问题打下坚实基础。。内容来源于网络分享,如有侵权请联系我删除。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值