【二分图匹配】 hdu3605 Escape

Escape

http://acm.hdu.edu.cn/showproblem.php?pid=3605

Problem Description
2012 If this is the end of the world how to do? I do not know how. But now scientists have found that some stars, who can live, but some people do not fit to live some of the planet. Now scientists want your help, is to determine what all of people can live in these planets.
 

Input
More set of test data, the beginning of each data is n (1 <= n <= 100000), m (1 <= m <= 10) n indicate there n people on the earth, m representatives m planet, planet and people labels are from 0. Here are n lines, each line represents a suitable living conditions of people, each row has m digits, the ith digits is 1, said that a person is fit to live in the ith-planet, or is 0 for this person is not suitable for living in the ith planet.
The last line has m digits, the ith digit ai indicates the ith planet can contain ai people most..
0 <= ai <= 100000
 

Output
Determine whether all people can live up to these stars
If you can output YES, otherwise output NO.
 

Sample Input
  
  
1 1 1 1 2 2 1 0 1 0 1 1
 

Sample Output
  
  
YES NO

二分图的多重匹配问题,也可以用匈牙利算法解决,具体思路见代码。


#include<cstdio>
#include<cstring>
using namespace std;
#define N 100005
#define M 12
int map[N][M];//i适合在j上生存
int cap[M];//星球的容量
int num[M];//星球上人数
int link[M][N];//i星球上居住了哪些人
bool visit[M];
bool dfs(int x,int m)
{
    for(int i=0;i<m;++i)//枚举每个星球
    {
        if(!visit[i]&&map[x][i])
        {
            visit[i]=true;
            if(num[i]<cap[i])//i星球上人数小于容量
            {
                link[i][num[i]++]=x;
                return true;
            }
            for(int j=0;j<num[i];++j)
            {
                if(dfs(link[i][j],m))//给link[i][j]找新的星球
                {
                    link[i][j]=x;
                    return true;
                }
            }
        }
    }
    return false;
}
int main()
{
    int n,m;
    for(bool flag=true;~scanf("%d%d",&n,&m);flag=true)
    {
        for(int i=0;i<n;++i)
            for(int j=0;j<m;++j)
                scanf("%d",&map[i][j]);
        for(int i=0;i<m;++i)
            scanf("%d",&cap[i]);
        memset(num,0,sizeof(num));
        for(int i=0;i<n;++i)//匈牙利算法
        {
            memset(visit,false,sizeof(visit));
            if(!dfs(i,m))
            {
                flag=false;
                break;
            }
        }
        if(flag)  puts("YES");
        else      puts("NO");
    }
    return 0;
}
来源: http://blog.csdn.net/ACM_Ted

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值