Time Java代码(简单模拟)

Time

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

Digital clock use 4 digits to express time, each digit is described by 3*3 characters (including”|”,”_”and” “).now given the current time, please tell us how can it be expressed by the digital clock.

Input

There are several test cases.

Each case contains 4 integers in a line, separated by space.

Proceed to the end of file.

Output

 For each test case, output the time expressed by the digital clock such as Sample Output.

Sample Input

1 2 5 6
2 3 4 2

Sample Output

    _  _  _ 
  | _||_ |_ 
  ||_  _||_|
 _  _     _ 
 _| _||_| _|
|_  _|  ||_ 

Hint

 

Source

import java.util.Scanner;

public class Main {//把所有的数字都打出来。
    public static void main(String[] args) {
        Scanner reader = new Scanner(System.in);
        int a[] = new int[4];
        while(reader.hasNext())
        {
            a[0]=reader.nextInt();
            a[1]=reader.nextInt();
            a[2]=reader.nextInt();
            a[3]=reader.nextInt();
            for(int i=1;i<=3;i++)
            {
                if(i==1)
                {
                    for(int j=0;j<4;j++)
                    {
                        if(a[j]==1||a[j]==4)
                            System.out.print("   ");
                        else System.out.print(" _ ");
                    }
                    System.out.println();
                }
                if(i==2)
                {
                    for(int j=0;j<4;j++)
                    {
                        if(a[j]==1||a[j]==7)
                            System.out.print("  |");
                        else if(a[j]==2||a[j]==3)
                            System.out.print(" _|");
                        else if(a[j]==0)
                            System.out.print("| |");
                        else if(a[j]==4||a[j]==8||a[j]==9)
                            System.out.print("|_|");
                        else if(a[j]==5||a[j]==6)
                            System.out.print("|_ ");
                    }
                    System.out.println();
                }
                if(i==3)
                {
                    for(int j=0;j<4;j++)
                    {
                        if(a[j]==0||a[j]==6||a[j]==8)
                            System.out.print("|_|");
                        else if(a[j]==1||a[j]==7||a[j]==4)
                            System.out.print("  |");
                        else if(a[j]==2)
                            System.out.print("|_ ");
                        else if(a[j]==3||a[j]==5||a[j]==9)
                            System.out.print(" _|");
                    }
                    System.out.println();
                }
            }
        }
        reader.close();
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值