1069 The Black Hole of Numbers (20 分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the 
digits in non-increasing order first, and then in non-decreasing order, a new number can 
be obtained by taking the second number from the first one. Repeat in this manner we will
 soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named
  Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0,10
​4
​​ ).

Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else 
print each step of calculation in a line until 6174 comes out as the difference. All the
 numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000
这种题给我的感觉就是多少有点坑,,,,
虽然很简单,基本上不需要什么算法,但是很容易疏忽一些细节。
这个题的坑就是6174本身。。
如果输入:6174
应该输出:7641-1467=6174
下面是AC的代码:
#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
bool cmp(int a,int b)
{
    return a>b;
}
int main()
{
    int n;
    int a[4];
    scanf("%d",&n);
    while(1)
    {
        for(int i=0; i<4; i++)a[i]=0;
        int index = 0;
        int m = n;
        while(n>0)
        {
            a[index++] = n%10;
            n = n/10;
        }
        if(a[0]==a[1]&&a[1]==a[2]&&a[2]==a[3])
        {
            printf("%04d - %04d = 0000\n",m,m);
            break;
        }
        sort(a,a+4);
        int s = 0;
        for(int i=0; i<4; i++)
        {
            s = s*10+a[i];
        }
        sort(a,a+4,cmp);
        int r = 0;
        for(int i=0; i<4; i++)
        {
            r = r*10+a[i];
        }
        printf("%04d - %04d = %04d\n",r,s,r-s);
        n=r-s;
        if(n==6174)
            break;
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值