1069 The Black Hole of Numbers (20分)

题目

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N N N in the range ( 0 , 1 0 4 ) (0,10^4) (0,104).

Output Specification:

If all the 4 digits of N N N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

代码

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

bool cmp1(int a, int b){
    return a > b;
}

bool cmp2(int a, int b){
    return a < b;
}

int trans(int n, int flag){
    vector<int> temp;
    for(int i=0; i<4; i++) {
        temp.push_back(n%10);
        n /= 10;
    }
    if(flag == 1)
        sort(temp.begin(), temp.end(), cmp1);
    else
        sort(temp.begin(), temp.end(), cmp2);
    int res = 0;
    for(int i=0; i<4; i++)
        res = res*10 + temp[i];
    return res;
}

int main(){
    int n, maxn, minn, temp;
    scanf("%d", &n);
    maxn = trans(n, 1);
    minn = trans(n, -1);
    if(maxn == minn){
        printf("%d - %d = 0000\n", maxn, minn);
    }
    else{
        temp = maxn - minn;
        while(temp != 6174){
            printf("%04d - %04d = %04d\n", maxn, minn, temp);
            maxn = trans(temp, 1);
            minn = trans(temp, -1);
            temp = maxn - minn;
        }
        printf("%04d - %04d = %04d\n", maxn, minn, temp);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值