数据结构实验之二叉树二:遍历二叉树

Problem Description
已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中
序和后序的方式遍历该二叉树。

Input
连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output
每组输入数据对应输出2行:
第1行输出中序遍历序列;
第2行输出后序遍历序列。

 

Sample Input
abc,,de,g,,f,,,
Sample Output
cbegdfa
cgefdba
AC代码:
#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node
{
    char data;
    struct node *l;
    struct node *r;
};
int top;
struct node *create(struct node *root,char str[])
{
    //只能这里的top自增,下面的else里面的不用。
    if(str[++top]==',')
        root = NULL;
    else
    {
        root = (struct node *)malloc(sizeof(struct node));
        root->data = str[top];
        root->l = create(root->l,str);
        root->r = create(root->r,str);
    }
    return root;
}
void zhongxu(struct node *root)
{
    if(root)
    {
        zhongxu(root->l);
        printf("%c",root->data);
        zhongxu(root->r);
    }
    return;
}
void houxu(struct node *root)
{
    if(root)
    {
        houxu(root->l);
        houxu(root->r);
        printf("%c",root->data);
    }
    //还是没有真正的明白递归的魅力
//    printf("\n");
    return;
}
int main()
{
    char str[55];
    struct node *root;
    while(~scanf("%s",str))
    {
        top = -1;
        root = NULL;
        root = create(root,str);
        zhongxu(root);
        printf("\n");
        houxu(root);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值