FatMouse' Trade

Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

一道英文题,简单翻译一下,就是老鼠拿猫粮去跟看守仓库的猫作交换想到尽可能多的自己喜欢的食物 。
输入拥有猫粮数,仓库数,和每个仓库内食物的数量和需要的猫粮数
题解:只有优选选择单位几个最低的仓库去交易就可以了

CODE:

#include <iostream>
#include <algorithm>
using namespace std;

struct room {
    double j, f, r;
} rooms[5000];
bool cmp ( room a , room b )
{
    return a.r > b.r ;
}

int main()
{
    int m, n, i, j, flag;
    double sum ;
    while ( scanf( "%d %d" , &m , &n ) != EOF )
    {
        if ( m == -1 && n == -1 )
            break;

        for ( i = 0 ; i < n ; i++ )
        {
            scanf ( "%lf %lf" , &rooms[i].j , &rooms[i].f );
            rooms[i].r = rooms[i].j / rooms[i].f;//计算单位价格
        }           
        sort ( rooms , rooms + n , cmp );

        sum = 0; 
        flag = 0;
        for ( i = 0 ; i < n ; i++ )
        {
            if ( m == 0 )
                break;
            if ( m >= rooms[i].f )//如果可以把整个仓库买完
            {
                m -= rooms[i].f;
                sum += rooms[i].j;
            }
            else//如果不够一个仓库的钱
            {
                sum += m * rooms[i].r;
                break;
            }
        }   
        printf ( "%.3lf\n" , sum ); 
    }   
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值