HDU 5763 Another Meaning(多校4)

Another Meaning

Problem Description
As is known to all, in many cases, a word has two meanings. Such as “hehe”, which not only means “hehe”, but also means “excuse me”. 
Today, ?? is chating with MeiZi online, MeiZi sends a sentence A to ??. ?? is so smart that he knows the word B in the sentence has two meanings. He wants to know how many kinds of meanings MeiZi can express.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each test case contains two strings A and B, A means the sentence MeiZi sends to ??, B means the word B which has two menaings. string only contains lowercase letters.

Limits
T <= 30
|A| <= 100000
|B| <= |A|

 

Output
For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the number of the different meaning of this sentence may be. Since this number may be quite large, you should output the answer modulo 1000000007.
 

Sample Input
  
  
4 hehehe hehe woquxizaolehehe woquxizaole hehehehe hehe owoadiuhzgneninougur iehiehieh
 

Sample Output
  
  
Case #1: 3 Case #2: 2 Case #3: 5 Case #4: 1
Hint
In the first case, “ hehehe” can have 3 meaings: “*he”, “he*”, “hehehe”. In the third case, “hehehehe” can have 5 meaings: “*hehe”, “he*he”, “hehe*”, “**”, “hehehehe”.
题意:
给定两个字符串,问第二个串在第一个串中可以最多可以表现多多少种不同的意思
题解:
直接上KMP找出对于第一个字符串的Pos位置的前缀和第二个字符串相同的所有位置,直接dp就可以了,听说数据很水的样子。
HDUOJ不能用next关键字当做数组名,导致CE一发,以后记住了。
#include <algorithm>
#include <iostream>
#include <numeric>
#include <cstring>
#include <iomanip>
#include <string>
#include <vector>
#include <cstdio>
#include <queue>
#include <stack>
#include <cmath>
#include <map>
#include <set>
#define LL long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int Mod = 1000000007;
const double esp = 1e-6;
const double PI = 3.1415926535898;
const int INF = 0x3f3f3f3f;
using namespace std;

char s[100005],t[100005];
bool vis[100005];
int Next[100005];
LL dp[100005];

void getnext(){
    int i=0,j=-1;
    Next[0]=-1;
    while(t[i]!='\0'){
        if(j==-1||t[i]==t[j]){
            i++;
            j++;
            Next[i]=j;
        }
        else{
            j=Next[j];
        }
    }
}

void kmp(){
    memset(vis,false,sizeof(vis));
    int i = 0,j = 0;
    getnext();
    int len1=strlen(s),len2=strlen(t);
    while(i<len1){
        if(j==-1||s[i]==t[j]){
            i++;
            j++;
        }
        else
            j=Next[j];
        if(j>=len2){
             vis[i] = true;
             j = Next[j];
        }
    }
}
int main(){
    int n , z = 1;
    scanf("%d%*c",&n);
    while(n--){
        gets(s);
        gets(t);
        kmp();
        int len = strlen(s);
        int len2  = strlen(t);
        dp[0] = 1;
        for(int i=1;i<=len;i++){
            dp[i] = dp[i-1];
            if(vis[i]){
                dp[i] = (dp[i]+dp[i-len2])%Mod;
            }
        }
        printf("Case #%d: %lld\n",z++,dp[len]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值