(HDU - 5763)Another Meaning

7 篇文章 0 订阅

(HDU - 5763)Another Meaning

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1827 Accepted Submission(s): 880

Problem Description

As is known to all, in many cases, a word has two meanings. Such as “hehe”, which not only means “hehe”, but also means “excuse me”.
Today, ?? is chating with MeiZi online, MeiZi sends a sentence A to ??. ?? is so smart that he knows the word B in the sentence has two meanings. He wants to know how many kinds of meanings MeiZi can express.

Input

The first line of the input gives the number of test cases T; T test cases follow.
Each test case contains two strings A and B, A means the sentence MeiZi sends to ??, B means the word B which has two menaings. string only contains lowercase letters.

Limits
T <= 30
|A| <= 100000
|B| <= |A|

Output

For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the number of the different meaning of this sentence may be. Since this number may be quite large, you should output the answer modulo 1000000007.

Sample Input

4
hehehe
hehe
woquxizaolehehe
woquxizaole
hehehehe
hehe
owoadiuhzgneninougur
iehiehieh

Sample Output

Case #1: 3
Case #2: 2
Case #3: 5
Case #4: 1

Hint

In the first case, “ hehehe” can have 3 meaings: “*he”, “he*”, “hehehe”.
In the third case, “hehehehe” can have 5 meaings: “*hehe”, “he*he”, “hehe*”, “**”, “hehehehe”.

题目大意:给出一个文本串和模式串,如果文本串的子串匹配模式串的话就可以把这个子串换成“*”号,也可以不变,问这样操作之后文本串可以变成几种形式。

思路:先用kmp把能匹配的地方找出来,然后用dp求解。设f[i]代表以i结尾的形式一共有几种,那么易得状态转移方程为:如果以i位置结尾的字符串无法匹配,那么 f[i]=f[i1] ;如果可以匹配那么 f[i]=(f[i]+f[im]) ,其中m为模式串的长度,ps:i-m可能会小于0,所以特判一下,上述第一个等式代表不变换成“*”号,第二个等式代表变换成“*”号

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn=100005;
const int mod=1000000007;
char s1[maxn],s2[maxn];
int Next[maxn];
int Hash[maxn],f[maxn];

void getNext(int m)
{
    Next[0]=Next[1]=0;
    for(int i=1;i<m;i++)
    {
        int j=Next[i];
        while(j&&s2[i]!=s2[j]) j=Next[j];
        if(s2[i]==s2[j]) Next[i+1]=j+1;
        else Next[i+1]=0;
    }
} 

void kmp(int n,int m)
{
    int j=0;
    for(int i=0;i<n;i++)
    {
        while(j&&s1[i]!=s2[j]) j=Next[j];
        if(s1[i]==s2[j]) j++;
        if(j==m) Hash[i]=1;
    }
}

int main()
{
    int T,kase=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s%s",s1,s2);
        int n=strlen(s1),m=strlen(s2);
        memset(Hash,0,sizeof(Hash));
        memset(f,0,sizeof(f));
        getNext(m);
        kmp(n,m);
        if(Hash[0]) f[0]=2;
        else f[0]=1;
        for(int i=1;i<n;i++)
        {
            f[i]=f[i-1];
            if(Hash[i]) f[i]=(f[i]+f[max(i-m,0)])%mod;
        }
        printf("Case #%d: %d\n",kase++,f[n-1]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值