hdu 1509 Windows Message Queue<priority_queue>

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1905 Accepted Submission(s): 745


Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

Sample Input
  
  
GET PUT msg1 10 5 PUT msg2 10 4 GET GET GET

Sample Output
  
  
EMPTY QUEUE! msg2 10 msg1 10 EMPTY QUEUE!

Author
ZHOU, Ran

Source

Recommend
linle
 
 
#include<iostream>
#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
struct node
{
    //string s;
    char s[20];
    int value;
    int ji;
    int k;
    friend bool operator<(node a,node b)
    {
            if(a.ji!=b.ji)return a.ji>b.ji;
            else return a.k>b.k;
    }
    //friend bool operator>(const node &a,const node &b)
   // {
     //       if(a.ji!=b.ji)return a.ji>b.ji;
     //       else return a.k>b.k;
    //}
}temp;
//priority_queue<node,vector<node>,greater<node> > t;
priority_queue<node> t;
int main()
{
    int k=0;
   // int value,ji;
    char s[5];
    while(~scanf("%s",s))
    {
        //cin>>s;
        if(s[0]=='P')
        {
            //cin>>msg;
            //scanf("%s",msg);
            scanf("%s%d%d",temp.s,&temp.value,&temp.ji);
            //temp.s=msg;
            //temp.value=value;
            //emp.ji=ji;
            temp.k=k++;
            t.push(temp);
        }
        else
        {
            if(t.empty()==true)
            {
                printf("EMPTY QUEUE!\n");
            }
            else
            {
                //cout<<t.top().s;
                temp=t.top();
                printf("%s %d\n",temp.s,temp.value);
                t.pop();
            }
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值