月饼

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有3种月饼,其库存量分别为18、15、10万吨,总售价分别为75、72、45亿元。如果市场的最大需求量只有20万吨,那么我们最大收益策略应该是卖出全部15万吨第2种月饼、以及5万吨第3种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:

每个输入包含1个测试用例。每个测试用例先给出一个不超过1000的正整数N表示月饼的种类数、以及不超过500(以万吨为单位)的正整数D表示市场最大需求量。随后一行给出N个正数表示每种月饼的库存量(以万吨为单位);最后一行给出N个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后2位。

输入样例:
3 20
18 15 10
75 72 45
输出样例:
94.50

解:(不知道为什么在PAT上全部都超时了-_-!!)

public class Main {

	public static void insertSort(Mooncake[] a) {
		for (int i = 1; i < a.length; i++) {
			Mooncake temp = a[i];
			int j = i;
			while (j > 0 && temp.price <= a[j - 1].price) {
				a[j] = a[j - 1];
				j--;
			}
			a[j] = temp;
		}
	}

	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		int n = in.nextInt();
		Mooncake[] m = new Mooncake[n];
		int max = in.nextInt();
		for (int i = 0; i < n; i++) {
			m[i] = new Mooncake();
			m[i].store = in.nextInt();
		}
		for (int i = 0; i < n; i++) {
			m[i].total = in.nextInt();
			m[i].price = m[i].total / (double) m[i].store;
		}
		insertSort(m);
		double earn = 0;
		for (int i = n - 1; i >= 0; i--) {
			if (max > m[i].store) {
				max -= m[i].store;
				earn += m[i].total;
			} else {
				earn += m[i].price * max;
				break;
			}
		}
		System.out.printf("%.2f", earn);
	}
}

class Mooncake {
	int store;
	int total;
	double price;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值