Binary Tree(树)

B - Binary Tree
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Background
Binary trees are a common data structure in computer science. In this problem we will look at an infinite binary tree where the nodes contain a pair of integers. The tree is constructed like this: 
  • The root contains the pair (1, 1). 
  • If a node contains (a, b) then its left child contains (a + b, b) and its right child (a, a + b)

Problem
Given the contents (a, b) of some node of the binary tree described above, suppose you are walking from the root of the tree to the given node along the shortest possible path. Can you find out how often you have to go to a left child and how often to a right child?

Input

The first line contains the number of scenarios. 
Every scenario consists of a single line containing two integers i and j (1 <= i, j <= 2*10  9) that represent 
a node (i, j). You can assume that this is a valid node in the binary tree described above.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing two numbers l and r separated by a single space, where l is how often you have to go left and r is how often you have to go right when traversing the tree from the root to the node given in the input. Print an empty line after every scenario.

Sample Input

3
42 1
3 4
17 73

Sample Output

Scenario #1:
41 0

Scenario #2:
2 1

Scenario #3:
4 6

运用树的思想。

题意大概为,设树点为(a , b)树根为(1 , 1) 的按照左孩子为(a + b , b) , 右孩子为 (a , a + b) 的一棵树。

求输入树点时,到该店应该左转多少次和右转多少次。

以 和 的大小作为区别,分别求要向左转多少次,向右转多少次。

当 x > y 时,树点作为左孩子位于树的左叉,即左转;

当 x < y 时,树点作为孩子位于树的叉,即转;

因为在树的终边为(1 , b)或者(a , 1),那么我们可以通过 (大数 - 1) / 小数 来求出当回到大数小于小数时走了多少次,即转了多少次。

最终我们可以总结为:左(右)转的次数 * 当前小数 + 1 = 当前大数 , 而求次数即倒过来求。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<utility>
#include<string>
#include<vector>
#include<algorithm>
#include<queue>
#include<cstdlib>
#include<cmath>
#include<stack>

using namespace std;

int main()
{
#ifndef ONLINE_JUDGE
	freopen("1.txt","r",stdin);
#endif
	int t , flag = 1 ;
	cin >> t ;
	while (t--)
	{
		printf("Scenario #%d:\n",flag++);
		int x , y ;
		cin >> x >> y ;
		int r = 0 , l = 0 ;
		while(x > 1 || y > 1)
		{
			if(x > y)
			{
				l += (x - 1) / y ;
				x -= (x - 1) / y * y ;
			}
			else
			{
				r += (y - 1) / x ;
				y -= (y - 1) / x * x ;
			}
		}
		printf("%d %d\n\n",l,r);
	}

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值