PAT(乙级)1042.统计字符(20)

1042.统计字符(20)

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:
输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。

输出格式:
在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:

This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........

输出样例:
e 7

题目分析:排序+数组hash使用+读取带空格字符串等技术

AC代码:

#include <vector>
#include <algorithm>
#include <string>
#include <iostream>
using namespace std;
const int max_n = 130;
int arr[max_n];

struct node{
    char c;
    int cnt;

    node(char c, int cnt){
        this->c = c;
        this->cnt = cnt;
    }
};

vector<node> vec;

bool cmp(node a, node b){
    if(a.cnt!=b.cnt)
        return a.cnt > b.cnt;
    else
        return a.c < b.c;
}

void transform(string& s){
    for(int i=0; i<s.length(); ++i){
        if(s[i]>='A' && s[i]<='Z')
            s[i] += 32;
    }
}

int main(){
    //freopen("in.txt", "r", stdin);
    fill(arr, arr+max_n, 0);
    string s;
    getline(cin, s);
    transform(s);
    for(int i=0; i<s.length(); ++i){
        if( (s[i]>='a'&&s[i]<='z')){
            arr[(int)s[i]] ++;
        }
    }

    for(int i=0; i<max_n; ++i){
        if(arr[i]!=0){
            vec.push_back(node(i, arr[i]));
        }
    }
    sort(vec.begin(), vec.end(), cmp);
    printf("%c %d\n", vec[0].c, vec[0].cnt);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值