PAT(甲级)1050.String Subtraction(20)

PAT 1050.String Subtraction(20)

Given two strings S1 and S​2​​ , S=S1−S​2 is defined to be the remaining string after taking all the characters in S​2 from S1. Your task is simply to calculate S1−S2 for any given strings. However, it might not be that simple to do it fast.

输入格式:
Each input file contains one test case. Each case consists of two lines which gives S​1​​ and S​2, respectively.The string lengths of both strings are no more than 10^​4. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

输出格式:
For each test case, print S​1−S2 in one line.

输入样例:

They are students.
aeiou

输出样例:

Thy r stdnts.

题目分析:数组hash的使用,因为题目要求s1-s2,因此开辟一个hash数组用来存放s2中出现的字符,然后遍历s1的所有字符,如果在hash数组中出现过就不输出。

注意:题目给出的字符串可能包含空格,因此不能使用cin进行输入,建议使用getline()进行输入。

AC代码:

#include <iostream>
#include <string>
using namespace std;
const int maxn = 128;
bool is_appear[maxn]={false};

int main(){
    string s1,s2;
    getline(cin, s1);
    getline(cin, s2);
    for(int i=0; i<s2.length(); ++i){
        is_appear[s2[i]] = true;
    }
    for(int i=0; i<s1.length(); ++i){
        if(!is_appear[s1[i]])
            cout<<s1[i];
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值