PAT(甲级)1105.Spiral Maxtrix(25)

PAT 1105 Spiral Matrix(25)
This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

输入格式:
Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10^​4. The numbers in a line are separated by spaces.

输出格式:
For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

输入样例:

12
37 76 20 98 76 42 53 95 60 81 58 93

输出样例:

98 95 93
42 37 81
53 20 76
58 60 76

题目分析:模拟题。

AC代码:

#include <iostream>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;

vector<int> v;

int main(void){
    int k, tmp;
    scanf("%d", &k);
    for(int i=0; i<k; ++i){
        scanf("%d", &tmp);
        v.push_back(tmp);
    }
    sort(v.begin(), v.end(), [](int a, int b){return a>b;});
    int n = floor(sqrt(1.0*k));
    while(k % n!=0)n--;
    int m = k / n;

    int arr[m][n];
    bool st[m][n];
    fill(st[0],st[0]+n*m,false);
    fill(arr[0],arr[0]+n*m,0);

    int idx = 0;
    int dx[4] = {-1,0,1,0},dy[4] = {0,1,0,-1};
    int x=0,y=0,d=1;

    for(int i=0; i<n*m; ++i){
        arr[x][y] = v[idx ++];
        st[x][y] = true;
        int a=x+dx[d], b=y+dy[d];

        if(a<0 || a>=m || b<0 || b>=n || st[a][b]){
            d = (d+1)%4;
            a = x+dx[d],b=y+dy[d];
        }
        x=a,y=b;
    }


    for(int i=0; i<m; ++i){
        for(int j=0; j<n; ++j){
            printf("%d",arr[i][j]);
            if(j!=n-1)printf(" ");
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值